Solved AMD Radeon HD 6470M (switchable graphics) driver problem with Windows 8 on HP Pavilion G6

Status
Not open for further replies.

Sven

Level 10
Joined
Nov 5, 2013
Messages
469
OS
Windows 7
Antivirus
Zemana
#1
Hello folks!

One of my friends having a problem with her laptop's switchable graphics (Intel & AMD Radeon) driver on Windows 8 OS. She wants to switch to Windows 8 from 7, but had issue with graphics driver. I also tried to help, downloaded the latest graphics driver for HP Pavilion G6 1215-et (64bit) named "SP59147" from the main site of HP, installed correctly but it says "WDDM 1.0.blablaba" on device manager, and shows its model as Radeon HD7000 with a caution sign..

I also searched the problem on the net a lot, but could not find anything, neither from HP support pages. Tried to install old but main driver from Win 7, it worked, but still had problems while switching, the game and videos didnt work well, also laptop heated itself a lot. Between all of these steps and the others, used Driver Fusion to clean/erase package remains, and restarted at each step.

Does any of you has a solution for that HD 6470M on Windows 8? Any idea/suggestions about it? All comments are welcomed! :)

Thanks :D
 

Purshu_Pro

Level 29
Trusted
Joined
Aug 3, 2013
Messages
1,847
OS
Windows 10
Antivirus
Emsisoft
#2
First thing, Plz let me know more detail of it, can u provide the screen shot that particular error?
 
Joined
Dec 21, 2013
Messages
5
#3
Hi,The driver won't work for me on win 8.1 .I have hp pavilion dv6 with VGA AMD Radeon HD 7400 M .I've installed the driver supposed to windows 8 .but it didn't work for me.all I did is I've opened Device Manager =>Display and updated the driver .It works perfect Now ..if this won't work you can use Device Doctor .
 

lassise

New Member
Joined
Dec 8, 2013
Messages
3
#5
Sometimes if you go to device manager (devmgmt.msc) and uninstall the driver then reboot the computer, plug & play will get the correct driver installed
 

Hesham

New Member
Joined
Jan 7, 2014
Messages
11
#7
mine is also 6470M graphic driver....mine laptop is HP Pavilion G41212tx....I had same problem sp59147 doesn't work in windows 8/8.1.....
while this one worked for me...give it a try :)
http://ftp.hp.com/pub/softpaq/sp58501-59000/sp58660.html
download link: http://ftp.hp.com/pub/softpaq/sp58501-59000/sp58660.exe
it doesn't work please tell me if u find any thing new
it show that i have "7400M" even i have 6470M
i unistall it and reboot then i used the package u give me ............
 
Joined
Jan 9, 2014
Messages
1
#10
Hai I got the way to solve it
I am using sony vaio sb18
I had faced the same problem.So to solve it just disable the existing graphics driver(I think some radeon 7500 or some thing...)
after that uninstall it.
Then download driver and patch from the sony site......(for me it is vaio that's why) corresponding to win 7 64 bit......
and install it ...never mind about the error messages appeared while installation.....after installation I hope your problem gets solve.....mine gets solved................
 

Hesham

New Member
Joined
Jan 7, 2014
Messages
11
#11
Hai I got the way to solve it
I am using sony vaio sb18
I had faced the same problem.So to solve it just disable the existing graphics driver(I think some radeon 7500 or some thing...)
after that uninstall it.
Then download driver and patch from the sony site......(for me it is vaio that's why) corresponding to win 7 64 bit......
and install it ...never mind about the error messages appeared while installation.....after installation I hope your problem gets solve.....mine gets solved................
well first thnx for sharing ur experience
and i already uninstalled it then report the computer and installed the new one ..
and i don't know what u mean by disable it can u explain more plz
 

Hesham

New Member
Joined
Jan 7, 2014
Messages
11
#16
i didn't try yet exams is burning my time but i finished up the one was killing me so i will try :D
 
Last edited:

Hesham

New Member
Joined
Jan 7, 2014
Messages
11
#18
well what happen is kind new
in the device manger : 6470M/7400M will the 6470M is the right one ...
7400 well this is the old not working one

and the catlyst is not working cause he doesn't detect any driver kind strange do u think i need to uninstall the one i have and retry
 

wrzs

New Member
Joined
Jan 6, 2013
Messages
6
#19
well what happen is kind new
in the device manger : 6470M/7400M will the 6470M is the right one ...
7400 well this is the old not working one

and the catlyst is not working cause he doesn't detect any driver kind strange do u think i need to uninstall the one i have and retry
6470M/7400M in the device manager seems correct to me.
Did you install the correct driver for your Intel card? I think you should install the 9.17.10.3347 version.
 

Hesham

New Member
Joined
Jan 7, 2014
Messages
11
#20
well what happen is kind new
in the device manger : 6470M/7400M will the 6470M is the right one ...
7400 well this is the old not working one

and the catlyst is not working cause he doesn't detect any driver kind strange do u think i need to uninstall the one i have and retry
ya sir i think i do
do u think i need to uninstall the old one before i install the new one ...
cause when i tried to install it
the computer freeze and it show me the sad face message ..
which said ur compute run into a problem bla bla bla ...
 
Status
Not open for further replies.
Forgot your password?