Troubleshoot Change dedicated video memory to 512mb?

RVS2

Level 3
Thread author
Verified
Oct 17, 2016
118
I wanted to increase my dedicated video memory from 256mb to 512mb, for playing games. What i did :

regedit - hkey local machine - created GMM folder - selected dword(32)bitvalue - named the folder DedicatedSegmentSize - entered 512 mb - and restarted.
--With a 4gb ram, 512mb was the highest recommended value--

But instead of giving 512 mb it put 1536 mb instead.
I then again changed it to 256 mb, but it shows 768 mb.

How should i reduce it to 512mb?

Untitled.png
 

Vasudev

Level 33
Verified
Nov 8, 2014
2,228
It is using part of your RAM as VRAM. Try using DDu to wipe your current driver and reinstall the driver again. That might reset the global variables.
 
Upvote 0

valvaris

Level 6
Verified
Well-known
Jul 26, 2015
263
Normaly you Dedicate the Memory for it over at the Bios / UEFI

No need for Registry Hack ;)

There you can regulate it accordingly with no issues and hardships.

But never forget:

Windows OS 64Bit needs about 1.2 - 1.6 GB Overhead plus applications that start up - The rest is for other applications to use!

Example: Windows OS 64bit 1.6 GB + 150 MB for AV and Startup Apps + 256 MB Video (Will be noted as Reserved on SystemInfo)= 2,006 GB Reserved 1,994 GB Free to use.

lmportant: On Windows 32bit RAM use max 3,2 GB - 3,6 GB depending on Mainboard and Windows OS Version

Rule: Since Windows 7 - 10 RAM gets calculated in MeBiByte - Here is a Converter for help: Convert mebibyte to megabyte - Conversion of Measurement Units (General Info)

Best regards
Val.
 
Upvote 0

RVS2

Level 3
Thread author
Verified
Oct 17, 2016
118
Normaly you Dedicate the Memory for it over at the Bios / UEFI

No need for Registry Hack ;)

There you can regulate it accordingly with no issues and hardships.

But never forget:

Windows OS 64Bit needs about 1.2 - 1.6 GB Overhead plus applications that start up - The rest is for other applications to use!

Example: Windows OS 64bit 1.6 GB + 150 MB for AV and Startup Apps + 256 MB Video (Will be noted as Reserved on SystemInfo)= 2,006 GB Reserved 1,994 GB Free to use.

lmportant: On Windows 32bit RAM use max 3,2 GB - 3,6 GB depending on Mainboard and Windows OS Version

Rule: Since Windows 7 - 10 RAM gets calculated in MeBiByte - Here is a Converter for help: Convert mebibyte to megabyte - Conversion of Measurement Units (General Info)

Best regards
Val.
I opened the bios but couldn't find these settings. I did the registry job after that .
 
Upvote 0

XhenEd

Level 28
Verified
Honorary Member
Top Poster
Content Creator
Well-known
Mar 1, 2014
1,708
I'm not sure if this is applicable to you:
  • Dedicated Memory Reporting

The graphics driver now reports some amount of fictitious “dedicated” graphics memory to the operating system (128MB by default) to work around applications issues in a number of games. These games incorrectly look for some amount of “dedicated” graphics memory because they weren’t coded with the unified memory architecture for processor graphics.

The amount reported can be modified or disabled if desired by changing the following registry value:


HKEY_LOCAL_MACHINE\Software\Intel\GMM, create a REG_DWORD value named “DedicatedSegmentSize”. The value is interpreted as number of MB to report (0-512MB). A value of 0 disables reporting the dummy memory segment. If the registry key/value is not found, the driver will report the default 128MB.
- - NEW- Intel® Iris™, Iris™ Pro, and HD Graphics Driver update posted for Haswell and Broadwell version 15.36.21.4222
 
Upvote 0

AK47 ING H

New Member
Sep 29, 2017
1
You have to change the value type from hexa decimal to decimal then you will see everything normal. Its simple xD
Cheers
AK47 ING H
 

Attachments

  • Untitled.png
    Untitled.png
    415.3 KB · Views: 2,781
  • Like
Reactions: Vasudev
Upvote 0

Mohammadjavad.ef

New Member
Oct 5, 2021
1
I wanted to increase my dedicated video memory from 256mb to 512mb, for playing games. What i did :

regedit - hkey local machine - created GMM folder - selected dword(32)bitvalue - named the folder DedicatedSegmentSize - entered 512 mb - and restarted.
--With a 4gb ram, 512mb was the highest recommended value--

But instead of giving 512 mb it put 1536 mb instead.
I then again changed it to 256 mb, but it shows 768 mb.

How should i reduce it to 512mb?

View attachment 142484
Hi. You set the amount with a hexadecimal value. You just need to correct it with a decimal value go to registery setting again and check the decimal option first , then set to 512, the program will set hexadecimal number automatically. Gl
 
  • Like
Reactions: Vasudev
Upvote 0

About us

  • MalwareTips is a community-driven platform providing the latest information and resources on malware and cyber threats. Our team of experienced professionals and passionate volunteers work to keep the internet safe and secure. We provide accurate, up-to-date information and strive to build a strong and supportive community dedicated to cybersecurity.

User Menu

Follow us

Follow us on Facebook or Twitter to know first about the latest cybersecurity incidents and malware threats.

Top