Andy Ful

Level 52
Verified
Trusted
Content Creator
@Andy Ful I think you can add the GPO tweak to disable on-access scan.
I could do it if I would work for MS to persuade people to use WD.:)
For some reason, MS does not want to apply this tweak by default in Windows Home and they know exactly how it works (but maybe they are just lazy).

This tweak can only solve the problem of some people with opening folders with many executables. This problem can be easily solved by using subfolders, without compromising the security. Most people do not store many executables in one folder and do not have such a problem. Other performance problems (copying files, installing/uninstalling applications, etc.) will be still present. Furthermore, it is not clear if the WD BAFS feature will work properly (it can be tested). The last problem is that MS could flag ConfigureDefender as a hack-tool, because of such an option that decreases the default security.
So, there are some pros and cons. I will investigate it in the feature.:)(y)
 
Last edited:

Andy Ful

Level 52
Verified
Trusted
Content Creator
Hi, Andy Ful, few days ago in another thread I showed you that on my PC, WD was making connection to smartscreen even for files without MOTW. I forgot to mention that my Cloud protection level is set to Block mode and max time to 60 secs via Configure_Defender. Did it make the difference?
It should not. It can probably depend on the privacy settings. SmartScreen events can be logged, and then it is evident that it can collect some data on the execution of any supported file (even without MOTW).
But, on my computer, the outgoing connections to SmartScreen servers are done only for files with MOTW. It is probable that I have more restrictive privacy settings.
 

SeriousHoax

Level 18
Verified
Malware Tester
It should not. It can probably depend on the privacy settings. SmartScreen events can be logged, and then it is evident that it can collect some data on the execution of any supported file (even without MOTW).
But, on my computer, the outgoing connections to SmartScreen servers are done only for files with MOTW. It is probable that I have more restrictive privacy settings.
My Privacy settings are pretty restrictive too. Uninstalled almost every preinstalled app via Windows10Debloater script, hardened many settings via Windows Privacy Dashboard and O&O ShutUP10 too. You're in Europe and I'm in Asia so maybe it's a region thing, maybe WD collects more stuff from here :unsure:
 

security123

Level 2
It is probable that I have more restrictive privacy settings.
My Privacy settings are pretty restrictive too. Uninstalled almost every preinstalled app via Windows10Debloater script, hardened many settings via Windows Privacy Dashboard and O&O ShutUP10 too. You're in Europe and I'm in Asia so maybe it's a region thing, maybe WD collects more stuff from here :unsure:
Maybe you both guys can make some posts on Tutorial - Protect your privacy in Windows 10 ? <3
 

security123

Level 2
Last edited: