overdivine

Level 2
Verified
for me it's not working. i would like to ditch chrome and use egde if this would work. maybe it's my settings. can anyone test please

Set New Tab page URL
Path: HKLM\Software\Policies\Microsoft\MicrosoftEdge\Internet Settings
Value name: NewTabPageUR
Value type: REG_SZ
Disabled: Blank
Enabled: Enter a URL in string format.

you can do this in group policy too

administrative templates- > windows components -> microsoft edge -> Set New Tab page URL

Annotation.png


thank you for your time

edit: must have 1809
 
Last edited:
  • Like
Reactions: Weebarra

Azure

Level 23
Verified
Content Creator
I believe what he meant was that a new tab can't be set to a specific web page in the browser. If it's possible, I haven't seen it. I use the blank page option since I dislike the MS stuff.
To clarify you both tried the settings > open Microsoft Edge with

- Start page
- New tab page
- Previous pages
- A specific page or pages

Right?
 

oldschool

Level 32
Verified
To clarify you both tried the settings > open Microsoft Edge with

- Start page
- New tab page
- Previous pages
- A specific page or pages

Right?
Not "Open Microsoft Edge with..", but :

"Open new tabs>
>top sites and suggested content
>top sites
>blank page
As far as I know, these are the only three options, which do not include setting "open new tabs" with a specific page.

Setting a specific page is only possible when "Setting>MS Edge to start with". I hope this clarifies what I believe OP is trying to accomplish. Maybe he can do it with W10 Pro or Enterprise. Not possible with Home edition as far as I know.
 

Local Host

Level 17
Verified
I believe what he meant was that a new tab can't be set to a specific web page in the browser. If it's possible, I haven't seen it. I use the blank page option since I dislike the MS stuff.
But it can be set to a specific page starting version 1809, which is the one he is using.
i need this to work
Group Policy and Mobile Device Management settings for Microsoft Edge (Microsoft Edge for IT Pros)

as stated you need Microsoft Edge on Windows 10, Version 1809 or later. i have windows enterprise .

the address is there but it's not loading. open Microsoft edge with works fine

View attachment 201432
You been messing with gpedit and regedit, so you can't mess with the option on Edge until you delete/disable those entries.
 

overdivine

Level 2
Verified
the setting are just how i want them to be. but no matter what url I chose for the new tab page it won't load.
what i am trying to say is that in windows 1809 you can set url for new tab page but at least for me that policy is not working and i don't know why.
the policy was introduced in windows 1809 and i guess that many didn't update because of random problems.
i want to know if someone tried it and if it works for them
 

Reldel1

Level 1
the setting are just how i want them to be. but no matter what url I chose for the new tab page it won't load.
what i am trying to say is that in windows 1809 you can set url for new tab page but at least for me that policy is not working and i don't know why.
the policy was introduced in windows 1809 and i guess that many didn't update because of random problems.
i want to know if someone tried it and if it works for them
I tried setting Edge using the Group Policy Administrative template to open https://bing.com for new tab pages. I can confirm it does not work in my 1809 build either.

Update: After adding the template, if I open Edge settings, General tab, the setting for opening new tabs shows a grayed out https://bing.com but the browser does not "honor" the setting and still shows the previous standard Edge new tab format. So, the template makes the change but Edge does not follow it. This may make Microsoft hold back on re-releasing the paused 1809 builds, LOL.
 
Last edited:

oldschool

Level 32
Verified
I tried setting Edge using the Group Policy Administrative template to open https://bing.com for new tab pages. I can confirm it does not work in my 1809 build either.

Update: After adding the template, if I open Edge settings, General tab, the setting for opening new tabs shows a grayed out https://bing.com but the browser does not "honor" the setting and still shows the previous standard Edge new tab format. So, the template makes the change but Edge does not follow it. This may make Microsoft hold back on re-releasing the paused 1809 builds, LOL.
@overdivine - sorry I forgot to mention I was using 1803 in my original post. I guess some of us had forgotten the 1809 release fiasco! :LOL:

I believe there have been reports of bugs in Edge, especially 1809. This thread is simply confirmation of one of them. Even 1803 had FP issues with VoodooShield version 4.65, which MS is still attempting to resolve. It is proving to a real brain-twister for MS!
 
Last edited:
  • Like
Reactions: Weebarra

Moonhorse

Level 26
Verified
Content Creator
I just use edge like this;
- Disable home button
+ add startpage to favorites and hide text

Takes bit of time to get familiar with it but i didnt found any other pleasant way to use edge
startpage.png