Firefox 95 enhances the browser's protection against malicious code

n8chavez

Level 9
Well-known
Feb 26, 2021
426
g
I'm not experiencing it. Can you link the website(s) you went to? BTW, I'm using Dark Reader

Well, pretty much every page I go to, and every one I've tried, shows a white screen before the page's content loads. This occurs with FF95, with Stylus and Dark Reader. This doesn't happen in FF94 or waterfox G4.
 
  • Like
Reactions: CyberTech

n8chavez

Level 9
Well-known
Feb 26, 2021
426
I'm using ExpressVPN, Surfshark VPN and VyprVPN. None of them pass the TLS 1.3 test at Clourflare site

Ummm....why so many VPNs? You know the old sang "If you have three quarterbacks, you actually have zero quarterback"? If you don't have one you trust you have none you should use.
 

HarborFront

Level 61
Thread author
Verified
Top poster
Content Creator
Oct 9, 2016
5,081
Ummm....why so many VPNs? You know the old sang "If you have three quarterbacks, you actually have zero quarterback"? If you don't have one you trust you have none you should use.
They work in China. Surfshark has double-hop feature
 

harlan4096

Moderator
Verified
Staff member
Malware Hunter
Well-known
Apr 28, 2015
7,969
FF95 here:

1638946631132.png
 

SecureKongo

Level 29
Verified
Top poster
Well-known
Feb 25, 2017
1,821
I think you need to set up Secure DNS and Encrypted SNI in FF before you can pass all the 4 tests. Read below


But I don't use secure DNS because I'm using VPN
Firefox doesn't have encrypted SNI anymore. They use ECH: Encrypted Client Hello: the future of ESNI in Firefox – Mozilla Security Blog

I get different results depending upon which vpn I use. It passes when I use the Bitdefender VPN.
Open the about:config settings in Firefox and try setting security.tls.version.max to 4 and security.tls.version.min to 3
Now Firefox only allows TLS v. 1.2 and 1.3
If the issue is actually related to your VPN then that's probably not the right solution.
 
Last edited:

n8chavez

Level 9
Well-known
Feb 26, 2021
426
Well, what the heck. The white screen issue for me started happening with FF95, happens in FF96, but does not happen in FF94 or Waterfox (based on FF92?). Maybe it's time for me to try Vivaldi, and see what v5.0 brings to the table.
 

CyberTech

Level 37
Verified
Top poster
Well-known
Nov 10, 2017
2,605
Well, what the heck. The white screen issue for me started happening with FF95, happens in FF96, but does not happen in FF94 or Waterfox (based on FF92?). Maybe it's time for me to try Vivaldi, and see what v5.0 brings to the table.

Try Private Window without Addons
 

Moonhorse

Level 32
Verified
Top poster
Content Creator
Well-known
May 29, 2018
2,187
Its insane how much single open tab eats memory on firefox...?
idlemb.png
 

SecureKongo

Level 29
Verified
Top poster
Well-known
Feb 25, 2017
1,821
Same. Nothing changed. The same things happens when I use a new profile too.
Maybe it is related to a security software that you have installed which delays the loading of the website. E.g. AdGuard Windows or an Antivirus that has problems with the new Firefox version?
 

n8chavez

Level 9
Well-known
Feb 26, 2021
426
Maybe it is related to a security software that you have installed which delays the loading of the website. E.g. AdGuard Windows or an Antivirus that has problems with the new Firefox version?

I don't think so. The only thing I use is sandboxie. Well, that and Windows Defender. But I turned off real-time scanning in Defender and saw no difference.
 
  • Like
Reactions: SecureKongo

n8chavez

Level 9
Well-known
Feb 26, 2021
426
Tried running Firefox outside the sandbox?

I have. Unfortunately, there was no difference. Now is appears that the beta of FF96 does not have this issue after the loading of the first site, after I load Firefox. It also does not appear to be related to using 3rd-party DNS service, such as ControlD. Curiouser and curiouser....
 
Last edited:

HarborFront

Level 61
Thread author
Verified
Top poster
Content Creator
Oct 9, 2016
5,081
Firefox doesn't have encrypted SNI anymore. They use ECH: Encrypted Client Hello: the future of ESNI in Firefox – Mozilla Security Blog


Open the about:config settings in Firefox and try setting security.tls.version.max to 4 and security.tls.version.min to 3
Now Firefox only allows TLS v. 1.2 and 1.3
If the issue is actually related to your VPN then that's probably not the right solution.
So, is the ESNI test at Cloudflare site no longer valid since the ESNI setting in FF95 no longer there?