Advanced Plus Security Gandalf_The_Grey's Security Config 2022

Last updated
Jun 7, 2022
About
Personal, primary device
Additional PC users
Not shared with other users
Desktop OS
Windows 11
OS edition
Pro
Login security
    • Password-less (PIN, Biometric, Face)
Primary sign-in
Microsoft account
Primary user
Admin user - Full permissions
Security updates
Automatic - allow all types of updates
Windows UAC
Maximum - always notify
Network firewall
Third-party router
Real-time protection
FS Protection by F-Secure 18.4 beta 7
VoodooShield 7.13
HomeCare by Trend Micro on TP-Link Archer AX6000 router
Software firewall
Microsoft Defender Firewall
Custom RTP, Firewall and OS settings
FS Protection
  • default
VoodooShield
  • AutoPilot Mode
  • WhitelistCloud enabled
Windows 11 Pro
Malware testing
No malware samples
Periodic security scanners
HitmanPro and Norton Power Eraser
Secure DNS
From my ISP (Ziggo)
VPN
AdGuard VPN (seldom used)
Password manager
Bitwarden browser extension
Browsers, Search and Addons
Microsoft Edge using Google search with uBlock Origin, Bitwarden, Browsing Protection by F-Secure (beta) and Microsoft Editor as extensions
Maintenance and Cleaning
Autoruns, CCleaner, Disk Cleanup, PatchMyPC, SUMo, Driver Easy and Winget (upgrade --all)
Personal Files & Photos backup
OneDrive with Microsoft 365 ransomware protection (always on sync)
Personal backup routine
Automatic (scheduled)
Device recovery & backup
Windows system image
Device backup routine
Manual (maintained by self)
PC activity
  1. Working from home. 
  2. Browsing the web. 
  3. Browsing to unknown sites. 
  4. Emails. 
  5. Shopping. 
  6. Banking. 
  7. Downloading software. 
  8. Remote assistance. 
  9. Multimedia. 
Computer specs
Personal changelog
2022.01.01 new config for the new year.
2022.01.31 removed Bitsum Process Lasso, Samsung Magician. Switched from DefenderUI Free and VoodooShield to the all-in-one DefenderUI Pro.
2022.02.12 back to Ziggo Safe Online by F-Secure
2022.02.16 added Quad9 secure DNS
2022.03.22 have to use Adobe Reader for work, removed KVRT.
2022.04.09 trying the AdGuard extension instead of uBlock Origin
2022.04.10 back to uBlock Origin
2022.05.01 removed Ziggo Safe Online, back to Microsoft Defender and installed Kerish Doctor
2022.05.04 installed the latest VoodooShield
2022.05.13 installed fs protection by F-Secure 18.4 beta 2
2022.05.20 back to Microsoft Defender Antivirus and Andy's tools
2022.05.23 changed from ConfigureDefender to DefenderUI
2022.06.07 backt to fs protection and VoodooShield
Feedback Response

Most critical feedback

Gandalf_The_Grey

Level 61
Thread author
Verified
Helper
Top poster
Content Creator
Well-known
Apr 24, 2016
5,009
Nope. Using a older version of CCleaner also create this issue.

I installed Opera latest stable version. Same thing happened there as in Edge. But just as with Edge, it's easy to get it back and working by simply manually disable the extension " Browsing protection " and then enable it again. Tested many times in both Edge and Opera with different banking sites. For now it's Firefox that works as it should. I'm sending the extra report probably on Monday or Tuesday. (y)
Thanks, it is a problem with all chromium-based browsers, CCleaner and F-Secure.
Disable and reenable "Allow access to file URLs" for the browsing protection extension also works.
Hope your report will speed up some troubleshooting by F-Secure (y)

As I believe not only banking protection but also https scanning is dependent on the extension and doesn't work anymore after cleaning with CCleaner.
I haven't tried any other cleaners.
 

upnorth

Moderator
Verified
Staff member
Malware Hunter
Well-known
Jul 27, 2015
4,857
Not having this issue anymore with FS Protection 18.4 beta 7 (y)
Got a reply back and they aren't able to reproduce it even with SAFE stable version 18.3. I can confirm the same as just tested again. Maybe some of the latest released extension updates for Browsing Protection fixed it? 🤷‍♂️
 

Gandalf_The_Grey

Level 61
Thread author
Verified
Helper
Top poster
Content Creator
Well-known
Apr 24, 2016
5,009
Got a reply back and they aren't able to reproduce it even with SAFE stable version 18.3. I can confirm the same as just tested again. Maybe some of the latest released extension updates for Browsing Protection fixed it? 🤷‍♂️
Strange, could be an extension, F-Secure module or even an Edge update, but I'm for sure glad that it is fixed now :unsure:
Thanks for (also) reporting it (y)