I contacted Dan from VoodooShield and this is what happened

RoboMan

Level 20
Content Creator
AV-Tester
Joined
Jun 24, 2016
Messages
990
OS
Windows 10
Antivirus
Microsoft
#1
A few days ago i noticed that with the new beta release, all problems were gone on everybody's computer, but in mine. Delay on opening programs was horrific for me and insane interface lagging. So i contacted VS developer, Dan, expecting an ordinary answer and no solution, what i'm used to.

A few hours after the first contact, Dan told me to download the new beta version. After testing it, my internet connection literally died. I told Dan about it and we both agreed that definitly VoodooShield wouldn't cause that. I used my backup image, no big deal.
Immediatly after that, when i thought i would get no further response, Dan showed up again and told me to try the previous release 3.50. This didn't fix it either. I was losing hope. We had exchanged 24 e-mails and things were not better... But once again, Dan popped up with more solutions.


From: VoodooShield Support Team
Sent: martes, 28 de febrero de 2017 2:21
To: XXXXX
Subject: RE: Many users having issues with lastest VS version

Oh wow… that does take a long time, sorry about that ;).

In Windows Control Panel / Region, what is the Format value set to? (The top setting).



----------------------------


Spanish (Spain, international)

Sent via Mail for Windows 10
Dan literally tried my config at his machine to test VoodooShield's settings.


From: VoodooShield Support Team
Sent: martes, 28 de febrero de 2017 18:27
To: XXXXX
Subject: RE: Many users having issues with lastest VS version

Thank you for letting me know… I tried it and it did not help.

Let me ask you this… what happens when you ping www.google.com?


----------------------------


C:\Users\Gonzi>ping www.google.com

Haciendo ping a www.google.com [181.30.244.119] con 32 bytes de datos:
Error general.
Error general.
Error general.
Error general.

Estadísticas de ping para 181.30.244.119:
Paquetes: enviados = 4, recibidos = 0, perdidos = 4
(100% perdidos),

Sent via Mail for Windows 10

After 26 e-mail exchange, Dan discovered my host machine had problems pinging Google or any host.


From: VoodooShield Support Team
Sent: martes, 28 de febrero de 2017 23:32
To: XXXXX
Subject: RE: Many users having issues with lastest VS version

Ok, then that is for sure what the issue is… VS pings google before it scans it with the blacklist or VoodooAi… and this would explain why it is delaying.

Do you have any idea why you cannot ping google?

---------------

After some research, my main security program may be blocking ping TO ANY HOST (not only Google). May Emsisoft be the cause?

Enviado desde Correo para Windows 10

---------------

From: VoodooShield Support Team
Sent: miércoles, 1 de marzo de 2017 0:09
To: XXXXX
Subject: RE: Many users having issues with lastest VS version

Hmmm, I am not sure… you might want to ask Emsisoft. You can always disable it and see what it does when it is disabled.

I need to find a better method for checking for an internet connection… but supposedly pinging google is the most reliable.

BTW, the reason it is taking so long is that it will try to ping google 3 times… and there is about a 10-20 second delay each time it tries to ping google.

If you figure out more, please let me know.

---------------

Dan,

I disabled Emsisoft Internet Security and pings worked again. Tried VS with EIS disabled and had no delay time (like old times!). What is left to find out why Emsisoft does this with pinging is my job. Thanks for all the support, you discovered the problem’s origin and now all i have to do is make a few emails and solve it. You were really helpful, thank you very much!

Sincerely,

I definitly was not expecting a developer to offer this kind of support, and actually investigating into my own settings to discover an issue that was not his fault neither his software's. I create this thread to give my huge thanks to Dan, show the community what a great support he is, and offer my case as a possible solution to anyone who has Emsisoft or any other security program that may be giving you this issue.

We love you Dan. :)
 

RoboMan

Level 20
Content Creator
AV-Tester
Joined
Jun 24, 2016
Messages
990
OS
Windows 10
Antivirus
Microsoft
#3
You can actually install TeamViewer (he as well) and then let him access your system for troubleshooting
I lost my faith in TeamViewer since i watched it be bypassed and hijacked hundreds of times :p

Anyways, i'd never ask a developer to get into my system to fix something his software was not causing. Rather find a solution on my own.
 

HarborFront

Level 38
Content Creator
Joined
Oct 9, 2016
Messages
2,701
#4
I lost my faith in TeamViewer since i watched it be bypassed and hijacked hundreds of times :p

Anyways, i'd never ask a developer to get into my system to fix something his software was not causing. Rather find a solution on my own.
Well if you suspect his program is causing problem to your system it's good to allow him to access your system for troubleshooting. You can always remove TeamViewer later if you don't need it

I have done that many times to allow Microsoft tech staff to access my system when I suspect my Microsoft Surface Pro 3/4 hardware is giving me problem
 
Last edited:

XhenEd

Level 27
Content Creator
Trusted
Joined
Mar 1, 2014
Messages
1,650
OS
Windows 10
Antivirus
Default-Deny
#5
Dan is really known to be a nice guy, except for those select few that say otherwise due to their own experiences with him.

For me, he's nice and accommodating, entertaining any useful ideas for the betterment of VS. :)
 

_CyberGhosT_

Level 52
Trusted
Joined
Aug 2, 2015
Messages
4,178
OS
Linux Mint
Antivirus
Default-Deny
#6
I have known Dan for a long time and I can tell you when I have as much faith in anyone as I have in him, it is
earned over time. Dan is a truly unique individual in the world of developers.
We have shared many professional and personal emails over the years,
I look forward to the Vegas party that looms in the future.
@Dan set a date dammit :p
@RoboMan
Glad you got to see that side of a good Developer / Friend.
 
Joined
Jul 6, 2015
Messages
669
OS
Windows 10
Antivirus
Avast
#7
Dans the man! and i find him very helpful and informative.
Its a shame not all devs are like him.

I have known Dan for a long time and I can tell you when I have as much faith in anyone as I have in him, it is
earned over time. Dan is a truly unique individual in the world of developers.
We have shared many professional and personal emails over the years,
I look forward to the Vegas party that looms in the future.
@Dan set a date dammit :p
@RoboMan
Glad you got to see that side of a good Developer / Friend.

Vegas uh?
Cant imagine you playing those $1 slot machines :p
 
Last edited by a moderator:

RoboMan

Level 20
Content Creator
AV-Tester
Joined
Jun 24, 2016
Messages
990
OS
Windows 10
Antivirus
Microsoft
#9
Did you follow up and contact Emsisoft for a response?
Yes, i emailed them and still waiting for a response. I'll update the thread when i get an answer that may help. :)

Did you guys notice my clickbait thread name? I had to come with a tricky name so you would enter to my thread muahaha
 
Last edited by a moderator:

RoboMan

Level 20
Content Creator
AV-Tester
Joined
Jun 24, 2016
Messages
990
OS
Windows 10
Antivirus
Microsoft
#15
Did you follow up and contact Emsisoft for a response?
It has been really a long time, but i just remember about this thread. Emsisoft's Support Team told me that when a network is not flagged as private (work/public), then the firewall will deny pings on the system. This was solved by trusting my Wi-Fi to Private.