Issues with _nomap and _optout on SSID's

Discussion in 'Other Security for Android and iOS' started by Slyguy, Jun 25, 2017.

  1. Slyguy

    Slyguy Level 21

    Jan 27, 2017
    1,098
    4,406
    Fortinet Engineer
    USA
    Other OS
    An issue has come up recently where my Samsung Galaxy s7 and s8 phones won't stay connected to my SSID that uses _nomap. Has anyone else run into this?

    For example my SSID is something like this: 6EFAq3C3ZLdY_optout_nomap

    Optout is to opt out of Windows 10 WiFi Sense crap. Nomap is to opt out of Google WiFi Spying and Mapping. I can connect to the SSID, router hands off DHCP, everything looks good then it gets into a constant connect/reconnect cycle.. If I swap to an SSID without _nomap it works just fine.

    Has anyone else run into this? I can't find a solution as of yet, other than perhaps Google in an update isn't honoring this OR Samsung has it disabled on their phones.. I can connect a Kindle Tablet to it fine (Hybrid Android)
     
    _CyberGhosT_ likes this.
  2. _CyberGhosT_

    _CyberGhosT_ Level 52
    Trusted

    Aug 2, 2015
    4,174
    27,489
    Retired
    Central US
    Linux Mint
    Default-Deny
    Hummm, this is a new one on me and I tinker with Android, at least in the past. Have you tried posting this over at XDA ?
    a few fellas over there that may be able to help: https://forum.xda-developers.com
     
    Slyguy likes this.
  3. Slyguy

    Slyguy Level 21

    Jan 27, 2017
    1,098
    4,406
    Fortinet Engineer
    USA
    Other OS
    I found the issue and wanted to follow up.

    The issue was, I forgot to add the new SSID to my RogueAP Suppression Whitelist on Fortinet. It viewed the new SSID as a rogue and DDOS attacked it each time a device tried to connect. So it's my oversight that caused it. Once I whitelisted the SSID for Android Devices, it fixed the issue.
     
Loading...