montanapratt

New Member
Hi there, I'm new here and looking for some help (I'm not sure if this is the right place, so if it's not please point me where I need to go). The homepage on my Safari has suddenly changed to http://localhost/?"\ and I'm unable to change it back to Google. I'm running macOS High Sierra 10.13.6 on a 2016 MacBook Pro. I've removed WeKnow adware (infected via Chrome) from the same computer months ago but have no other symptoms other than the homepage issue now. I 've had Malwarebytes installed/updated for years now and it's returning zero threats. I only updated my OS three days ago so I'm not sure if it's just an update glitch, but the issue only began appearing today.
 

Attachments

  • Like
Reactions: oldschool

montanapratt

New Member
Did you follow any guides to remove WeKnow adware?

There are some steps you can do before using Malwarebytes for macOS.
I had removed the WeKnow adware completely about 4 months ago - I think this time it’s something different but I can’t figure out what. Everything else about my safari is working as normal, no odd-looking webpages or extensions. Just the changed homepage.
 
  • Like
Reactions: oldschool

Jack

Level 85
Verified
Staff member
Hello @montanapratt,
Can you try these steps:
  1. In Safari, choose Preferences from the Safari menu.
  2. In the window that opens, click the General icon (if necessary)
  3. Enter your desired home page in the "Homepage" field, but DO NOT press return!
  4. At the top of the window, click any of the other icons (eg, Tabs, AutoFill, etc).
  5. You may see a prompt asking for confirmation for changing the home page. If so, confirm.
  6. Switch back to the General page and check to make sure the home page has been changed.
 

montanapratt

New Member
Hello @montanapratt,
Can you try these steps:
  1. In Safari, choose Preferences from the Safari menu.
  2. In the window that opens, click the General icon (if necessary)
  3. Enter your desired home page in the "Homepage" field, but DO NOT press return!
  4. At the top of the window, click any of the other icons (eg, Tabs, AutoFill, etc).
  5. You may see a prompt asking for confirmation for changing the home page. If so, confirm.
  6. Switch back to the General page and check to make sure the home page has been changed.
Thanks Jack, it worked! Would it have just been a weird glitch that caused it?
 
  • Like
Reactions: Jack

Jack

Level 85
Verified
Staff member
Would it have just been a weird glitch that caused it?
Yes, it's a Safari bug that needs to be fixed. It has been around for quite some time but no fix yet. Anyway, I'm happy that your computer is better now! : D