Q&A YouTube "comment failed to post"

Cleo

Level 3
May 25, 2020
133
No. It is not new. VPN use sometimes interferes or prevents the user from posting comments on Youtube.

You should post your question on the Youtube community support forum to see other similar reports. Your issue can arise from multiple things, but in the context of your post, it appears that you can add comments while not using the VPN.

Welcome to the YouTube Help Community

However your best bet is to submit a support ticket directly to Youtube for your paid premium account:

Get support for YouTube Paid Products

Opening a case there they will direct you to the required department.
I tried a different browser(Firefox w no extensions and Iridium) and a different premium account and a different vpn. The problem is specific to the one (main) vpn I use.
 

azariy

New Member
Aug 16, 2021
1
No. It is not new. VPN use sometimes interferes or prevents the user from posting comments on Youtube.

You should post your question on the Youtube community support forum to see other similar reports. Your issue can arise from multiple things, but in the context of your post, it appears that you can add comments while not using the VPN.

Welcome to the YouTube Help Community

However your best bet is to submit a support ticket directly to Youtube for your paid premium account:

Get support for YouTube Paid Productswork time

Opening a case there they will direct you to the required department.

Hi! I have same problem as author and wanted to ask you: have you ever dealed with their help community? Are they answering fast?
 
  • Like
Reactions: Nevi

Cleo

Level 3
May 25, 2020
133
Do you use a VPN that blocks ads ? If yes, then try disabling the VPN ad blocker.

Different elements on web page can be hosted on different servers. It is possible that the Youtube comment system is hosted on a content delivery network (CDN) of servers, and their domains\ip addresses were reported to the ad blocker and blacklisted. With the specific blocking you both are reporting using a specific VPN, a VPN-based ad blocker is the most plausible cause at this point.
I was using XEOVO via Wireguard (Sydney sever - port 51820) on a GL.iNET Slate. I can't see any add blocking so, yes, maybe its just the ip that is blacklisted but maybe not for ad blocking, maybe for bots or spam or some such.
 
Top