D

Deleted member 2913

Uninstalled Macrium.

And fixed the errors with chkdsk /f

By the way, is it safe to fix chkdsk errors with Macrium installed or Macrium have some tools to run & fix errors?
 
  • Like
Reactions: venustus
D

Deleted member 2913

I tried backup/restore with Todo Backup Workstation, Macrium Home & Aomei Backupper Pro (Didn't try restore with AB Pro)

Macrium Home - I liked it...its incremental backup/restore is fast i.e app 2-3 mins mostly...This is good especially when you try software often & revert to clean backup. But restore here gave chkdsk errors (still a solid product, such things may happen sometimes with these types of products). I liked its incremental backup/restore But its only in paid version And I dont have a license. Its a huge software app 1GB (guess due to recovery media & WinPE Pre-OS required software need to be downloaded).

Todo Backup Workstation - I like it...its incremental backup is fast & impressive i.e under 20 secs mostly. But incremental restore is not fast like Macrium. Incremental restore took 28 mins & everything was fine except Chome settings were corrupted But reset settings solved the issue. Not for users who try software often & revert to clean backup as restore takes little long time (but almost all imaging product take long time to restore except Macrium...its fast restore is worth the price i.e paid version). Its app 115 MB & includes media recovery & WinPE/Linux Pre-OS required stuffs & no need huge download like Macrium.

Aomei Backupper Pro - Its incremental backup took long time i.e more than 10 mins. I guess its incremental restore too will take long time so didn't try the restore operation.

As for me, I am back to Rollback Rx Pro. It too has its quirks like the above mentioned software & I can handle its quirks. And nothing beats the usablility, simplicity, speed, etc of Rollback Rx Pro...excellent for users who often try software & revert to clean state. Its perfect for users like me who backup their data externally & are ready to reinstall OS if anything goes wrong.