Can't add a firewall rule because a folder is named like an enviroment variable.

Status
Not open for further replies.
Joined
Oct 6, 2016
Messages
14
OS
Windows 10
Antivirus
Default-Deny
#1
I created a Portable App (BitKinex) with Cameyo.

When I execute the BitKinex.cameyo.exe, the real program is under this path:
"C:\Users\MyUserName\AppData\Roaming\VOS\BitKinex\PROG\%Program Files%\BitKinex\bitkinex.exe"

When I want to add a rule to the windows firewall, it doesn't work because it thinks %Program Files% is an enviroment variable, but its not - it is just an folder named like an enviroment variable.

When I make it with BiniSoft Interface, I simply don't get an rule.
When I make it with Windows Firewall with Advanced Security, I get following Error Msg:
An error occurred while adding a rule.

Error: The parameter is incorrect

Status: The application name could not be resolved​

I also tried it per CMD, with follwing command:
netsh advfirewall firewall add rule name="BitKinex" dir=out action=allow program="C:\Users\MyUserName\AppData\Roaming\VOS\BitKinex\PROG\%Program Files%\BitKinex\bitkinex.exe" enable=yes​
but then I get this error msg:
The application name could not be resolved.

I can not rename the folder, this just doesn't work with Cameyo.

Is there a workaround??
 
Status
Not open for further replies.