Firefox 95 enhances the browser's protection against malicious code

Sammo

Level 5
Verified
Well-known
Jan 27, 2012
216
Firefox doesn't have encrypted SNI anymore. They use ECH: Encrypted Client Hello: the future of ESNI in Firefox – Mozilla Security Blog


Open the about:config settings in Firefox and try setting security.tls.version.max to 4 and security.tls.version.min to 3
Now Firefox only allows TLS v. 1.2 and 1.3
If the issue is actually related to your VPN then that's probably not the right solution.
I already did this and FF 95 still fails the Cloudflare test. I believe the issue is with Firefox and it's handling of DoH. If I deselect this option the TLS test passes.
 
Last edited:
  • Sad
  • Like
Reactions: Kongo and Correlate

HarborFront

Level 62
Thread author
Verified
Top poster
Content Creator
Oct 9, 2016
5,186
I already did this and FF 95 still fails the Cloudflare test. I believe the issue is with Firefox and it's handling of DoH. If I deselect this option the TLS test passes.
Mine already pass the TLS 1.3 test at Cloudflare site.

1639022476464.png

If you are using uBO you need to allow some test sites to pass through

1639022526895.png

I did not enable DNS over HTTPS

1639022976036.png
 
Last edited by a moderator:

n8chavez

Level 11
Well-known
Feb 26, 2021
543
Ok. two things....One, I solved my issue! And, two, I am an idiot! It never occurred to me that I might need to update my userchrome.css file. But that's what was causing the issue.
 
  • Like
Reactions: oldschool and Kongo

Moonhorse

Level 33
Verified
Top poster
Content Creator
Well-known
May 29, 2018
2,231
Yeah...that's not right. For me Firefox is incredibly light. What extensions are you using with it?
Just bitwarden, it got fixed after browsing & went back to normal

And ESNI is long gone, i guess its because of quic development
 
  • Like
Reactions: oldschool
Top