Status
Not open for further replies.

Spirit

New Member
Hi,
I have some trouble in Internet speed today.The problem is when I check Internet speed from speedtest.net its nearby speed provided by my isp but webpages seem to open very slow in browser and many item on page are invisible.

But when I use vpn speed seems to see normal.
Even I checked by changing dns and cleaning all the stuffs still its happening.

Any Suggestions?
 

Spawn

Administrator
Verified
Staff member
Reboot your router.

Are they multiple devices connected to your network, using bandwidth?

I still remember the dial-up days (~56kbps), no complaints because it was better than nothing. :D
 

Spirit

New Member
Earth said:
Reboot your router.

Are they multiple devices connected to your network, using bandwidth?

I still remember the dial-up days (~56kbps), no complaints because it was better than nothing. :D

I use 3G Mobile and both my laptop/desktop have different device.
 

Littlebits

Retired Staff
Many things can cause slow speed issues.

First contact your ISP and see if they are having problems on their end.
Try using different browsers and see if the problem applies to all of them.
If your real-time AV has web protection try disabling it and see if the problem still exists.

Your modem could be having problems try restarting it if it has a reset button or unplug it wait for about a minute then plug it back in.

Make sure that your network connection settings are setup correctly and your Internet settings.

Enjoy!!:D
 
Status
Not open for further replies.