Q&A Turning off "Fast Startup" makes Windows (and other softwares) more stable and can solve many problems

F

ForgottenSeer 89360

My fast startup is enabled, but I always shut down my PC from a bat file I have created and keep in start menu, and it includes shutdown -s. This forces a normal shutdown, not the hybrid one. It’s too much hassle opening this old control panel and disabling it 😅

You can also hold shift key whilst pressing shutdown to bypass the hybrid shutdown.
 

SecurityNightmares

Level 40
Verified
Jan 9, 2020
2,955

SecurityNightmares

Level 40
Verified
Jan 9, 2020
2,955
It's possible to be done via PowerShell as well, I just did it now.
powercfg - h off
Okay but this disables sleep mode too. Specially if you want save some PC energy at lunchtime and you want end your work where you stop before.
If you fully shutdown, this isn't possible and you may forget where you stop working on.

just my 50c :D
 
F

ForgottenSeer 89360

Okay but this disables sleep mode too. Specially if you want save some PC energy at lunchtime and you want end your work where you stop before.
If you fully shutdown, this isn't possible and you may forget where you stop working on.

just my 50c :D
Oh dear :D
I just undid that and now I disabled from registry.
The value is located in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power\HiberbootEnabled
It should be 0.

Following command in cmd is helpful in that case:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /V HiberbootEnabled /T REG_dWORD /D 0 /F <-disable
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /V HiberbootEnabled /T REG_dWORD /D 1 /F <-enable

It needs to be ran with admin privileges.
 
Last edited by a moderator:

IkariGradius

Level 2
Verified
Jan 17, 2019
71
Fast Startup kind of scares me; it's like I flipped a switch and the desktop just comes on. I'm like: please don't crash, please don't crash🙏. Aside from physical Windows issues, I'm just uncomfortable with it enabled. Boot only takes like 8 or 9 seconds longer with it OFF anyway. Plus, I got lots of disk space back when I removed hibernate.sys.

Hmmm, I thought Fast Startup in theory would be more beneficial with older hardware with a hard disk drive as the boot drive. Is this wrong?
Same, when I turn my computer off I like it being completely shut down.

You’re right, Fast Startup is especially noticeable on older HDD, as boot is already quite fast with a SSD.
 

IkariGradius

Level 2
Verified
Jan 17, 2019
71
I followed the advice to shut off fast startup, and as soon as I did Kerish doctor sent me a pop up recommending me to reinstall{anyone else see this?}
I've never seen Fast Startup having an impact on a software this way. As Kerish Doctor monitors in real time processes and Windows services, this might be a bug. Are you sure it's not just a recommendation to turn Fast Startup on again ? If so, you should be able to discard it.

However I guess a restart should solve the problem. If the issue persist, you can reinstall Kerish Doctor as your license should be linked to your PC, so no reactivation should be necessary. If you have time, you could inform their support of the issue so that they might be able to fix it and give you an explanation as of what happened.

Let us know how it goes.
 

Evjl's Rain

Level 46
Verified
Trusted
Content Creator
Malware Hunter
Apr 18, 2016
3,549
On HDD, fast startup can make a day-and-night improvement in boot time -> highly recommend keeping it on

On SSD, fast startup make almost 0 difference but may increase write circle -> more SSD degradation -> better turn it off
indeed, disabling fast startup can make windows much more stable
 

Divine_Barakah

Level 27
Verified
May 10, 2019
1,621
No Brother I didn't but kind off pleased to see that Kerish doctor noticed the change, I am sticking to the advice received on the forum and going to leave it off,There have been no other notices from Kerish since, to reinstall
Well, I do trust Kerish Doctor and it never caused me any headaches. On the contrary, it helped me fix many issues (annoying ones like corrupted icon cache and whatsover). I know these issues can be fixed using CMD, but I like the one-click fix offered by Kerish. Regarding the Fast Startup, it is enabled here and I am not going to turn it off. Never had any issues except for G Data not appearing in system tray.
 

Dex4Sure

Level 3
May 14, 2019
112
Fast startup created issues for me as well, mostly to get RAM stable... So I disabled it from UEFI. Actually there was another fast boot setting "mrc fast boot" under ASUS UEFI settings... Disabled both. And I mean 2 different fast boot settings in UEFI. Fast boot skips RAM checks I think to make boot time slightly faster, but I don't think its worth it to trade off stability for few seconds faster boot honestly. Based on my own experience, I'd disable it every time.
 
Top