Advice Request Fedora on VMware

Please provide comments and solutions that are helpful to the author of this topic.

simmerskool

Level 31
Thread author
Verified
Top Poster
Well-known
Apr 16, 2017
2,073
I installed Fedora 37 workstation on VMware 16.2.5 and seems nice and stable, BUT I'm getting a lot of screen flickering but only with Firefox 110. Also posted at fedora forum and someone suggested that fedora is having a conflict between the hardware graphics and virtual graphics. I do NOT see flickering in win10 guest OS Otherwise Fedora is nice. I deleted Centos7 as it was had no sound and problems with video. Fedora is aok with sound and video.
 

Bot

AI-powered Bot
Apr 21, 2016
3,544
It's possible that the screen flickering issue you're experiencing with Firefox on Fedora 37 in VMware could be a result of graphics driver compatibility issues between the host and guest operating systems. You may want to try updating the graphics driver for your host System and installing the latest VMware tools for your guest operating system. Additionally, you can try disabling hardware acceleration in Firefox by going to Options > General > Performance and unchecking "Use recommended performance settings" and "Use hardware acceleration when available".
 
F

ForgottenSeer 98186

I installed Fedora 37 workstation on VMware 16.2.5 and seems nice and stable, BUT I'm getting a lot of screen flickering but only with Firefox 110. Also posted at fedora forum and someone suggested that fedora is having a conflict between the hardware graphics and virtual graphics. I do NOT see flickering in win10 guest OS Otherwise Fedora is nice. I deleted Centos7 as it was had no sound and problems with video. Fedora is aok with sound and video.
 

simmerskool

Level 31
Thread author
Verified
Top Poster
Well-known
Apr 16, 2017
2,073
It's possible that the screen flickering issue you're experiencing with Firefox on Fedora 37 in VMware could be a result of graphics driver compatibility issues between the host and guest operating systems. You may want to try updating the graphics driver for your host System and installing the latest VMware tools for your guest operating system. Additionally, you can try disabling hardware acceleration in Firefox by going to Options > General > Performance and unchecking "Use recommended performance settings" and "Use hardware acceleration when available".
Thanks, I diabled both as you suggested but flickering continues in Firefox 110 on Fedora.
 

Bot

AI-powered Bot
Apr 21, 2016
3,544
Thanks, I diabled both as you suggested but flickering continues in Firefox 110 on Fedora.
If disabling hardware acceleration did not resolve the issue, you can try to create a new Firefox profile and see if the issue persists. To do this, open a terminal and type "firefox -P" and click OK. Then click on "Create Profile..." and follow the steps to create a new profile. Once you have created the new profile, select it and try opening Firefox to see if the flickering issue is still there.

If the issue persists, it might be a graphics driver issue, and you may want to try updating to the latest graphics drivers or checking for any graphics-related settings in your host operating system that could be causing issues.
 

simmerskool

Level 31
Thread author
Verified
Top Poster
Well-known
Apr 16, 2017
2,073
Thanks, yeah I posted this flickering issue on fedoraforum last night, one reply so far, and I did see other threads about flickering on earlier versions, so this seems to be real issue. On MT website the flickering is minimal or almost non-existent, I'm waiting for a reply from VMware support. Otherwise, Fedora seems nicely solid.
 
  • Like
Reactions: vtqhtr413

simmerskool

Level 31
Thread author
Verified
Top Poster
Well-known
Apr 16, 2017
2,073
A FIX but not necessarily a solution. Fix is Chromium browser v111..64 (Fedora Project) and NO flickering with Chromium, which seems to put the Firefox flickering specifically with FF. And surprised as FF installs with Fedora OS, whereas I had DL Chromium and install it. In fairness, I have not re-tested FF yet as Chromium has bedazzled me on this VM 😁
 
  • Applause
Reactions: vtqhtr413

simmerskool

Level 31
Thread author
Verified
Top Poster
Well-known
Apr 16, 2017
2,073
UPDATE to flickering firefox: I may have FIXED it. I had to shutdown Fedora and then made an edit to its VMware settings, ie, I disabled accelerated 3D graphics and now in FF I'm not seeing any flickering. so 2 good browsers, have good sound & video. So far Fedora 37 rocks!! 😀
 

simmerskool

Level 31
Thread author
Verified
Top Poster
Well-known
Apr 16, 2017
2,073
I think the bot pegged it 👍
on this topic @Bot doing ok. but sometimes its answer are flat out incorrect, but it states them with no hesitation. It should post a confidence rating with its answers. Voodooshield gives a confidence level with its Ai valuations IIRC
 
  • Like
Reactions: vtqhtr413
F

ForgottenSeer 72227

UPDATE to flickering firefox: I may have FIXED it. I had to shutdown Fedora and then made an edit to its VMware settings, ie, I disabled accelerated 3D graphics and now in FF I'm not seeing any flickering. so 2 good browsers, have good sound & video. So far Fedora 37 rocks!! 😀
Glad you like it...it's my distro a choice. I like it because it's a nice balance of being up to date on the latest packages, but also being very stable. I am glad it was an easy fix...personally I've found that using 3D accleration in VMs causes more issues than good in most cases, so I just usually just leave it off.
 

About us

  • MalwareTips is a community-driven platform providing the latest information and resources on malware and cyber threats. Our team of experienced professionals and passionate volunteers work to keep the internet safe and secure. We provide accurate, up-to-date information and strive to build a strong and supportive community dedicated to cybersecurity.

User Menu

Follow us

Follow us on Facebook or Twitter to know first about the latest cybersecurity incidents and malware threats.

Top