DeepWeb

Level 24
Verified
Yup. The only way to turn it back off is disabling Hyper-V in BIOS for me. What were they thinking?

Keep it disabled. My CPU idle is at 2-5% with their Core Isolation nonsense enabled. It's not efficient at all. My laptop is burning my lap off. For what? A lil more security? That's not the way to go, Microsoft.
 

Local Host

Level 18
Verified
Yup. The only way to turn it back off is disabling Hyper-V in BIOS for me. What were they thinking?

Keep it disabled. My CPU idle is at 2-5% with their Core Isolation nonsense enabled. It's not efficient at all. My laptop is burning my lap off. For what? A lil more security? That's not the way to go, Microsoft.
You guys don't understand what you're doing then complain, core isolation is enabled by default (in systems that support it), while memory integrity is turned OFF due to Software incompatibilities (since the tech is still green and needs developers to port it over).
So by forcing memory integrity ON while not knowing what the hell you doing will always result in problems, also despite the bug (of not being able to turn if OFF in the UI), memory integrity will turn itself OFF if there's compatibility problems.
It was also made clear you can fix the problem by regedit.
I suggest doing some research before messing with Windows Settings.
 
  • Like
Reactions: oldschool

DeepWeb

Level 24
Verified
You guys don't understand what you're doing then complain, core isolation is enabled by default (in systems that support it), while memory integrity is turned OFF due to Software incompatibilities (since the tech is still green and needs developers to port it over).
So by forcing memory integrity ON while not knowing what the hell you doing will always result in problems, also despite the bug (of not being able to turn if OFF in the UI), memory integrity will turn itself OFF if there's compatibility problems.
It was also made clear you can fix the problem by regedit.
I suggest doing some research before messing with Windows Settings.
It's buggy regardless. It's not even showing anymore on my computer. The CPU overhead of Memory Integrity (which is a part of Core Isolation) is ridiculous and like I said once it's on, you can't turn it off so I don't see the point you are trying to make here. It's still BUGGY. Microsoft renaming features only adds to the confusion.
 

Local Host

Level 18
Verified
It's buggy regardless. It's not even showing anymore on my computer. The CPU overhead of Memory Integrity (which is a part of Core Isolation) is ridiculous and like I said once it's on, you can't turn it off so I don't see the point you are trying to make here. It's still BUGGY. Microsoft renaming features only adds to the confusion.
Nothing was renamed, and as I said it turns itself OFF by default if it detects compatibility issues, the OFF switch gets bugged when this happens.
Can still be reverted through regedit as I said.
I see no reason to mess with the Memory Integrity at this stage, as there lack of support from third-party developers and it's green tech.
 
Last edited:

HarborFront

Level 46
Verified
Content Creator
Simple registry hack can fix this issue:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity\Enabled
1=True
0=False
After enabling Core Isolation I checked the registry the Enabled = 0

So I changed it to Enabled =1. After reboot it comes back to Enabled = 0.......and Core Isolation remains enabled

I believe this registry hack is tied to Memory Integrity. I cannot enable Memory Integirty on my 2x MS tablets.....maybe due to old drivers

When I ran @RejZoR 's Core Isolation Tool it says Its disabled but I couldn't go back to the original Core Isolation state
 
Last edited:
D

Deleted member 178

Core Isolation switch off issue seems fixed , me and some mates don't have it anymore.