blackice

Level 13
Verified
I have a few friends on school who are strong advocates of ESET. When you have to spend time on learning how to tweak ESET (it has a great HIPS they say), why not just simply use DefenderConfigurator and max up WD? Why bother with HIPS, just run as basic user.

On Linux (Manjaro) I rarely need to enter my admin password to run elevated. When I boot into my Windows 10 partition I also see few UAC elevations requests. I have not rooted my Android phone either. Running admin is overrated IMO,
Because Configure Defender doesn’t have a marketing budget like ESET.
 

L0ckJaw

Level 11
Verified
Content Creator
I tried reinstalling on my other machine yesterday and had the same error....I really can't be bothered with Norton anymore...Shame...!
I really dont get the bug, using Norton 360 on many machines and never had the bug.
When buying Norton360 , they even migrated my old Norton Security license to 360, so over 660 days left and the licenses are not expensive.
 

alv222

Level 2
Same here but that "can't connect to Norton server" is a pain in the b#tt.
I'm using norton 360 and didnt have that issue, do you have internet explorer?
It's sort of phenomenally stupid that IE being the default browser would be the fix, or even the fact that Norton would use iFrames and ActiveX to activate their product. Also, that fix while working for some, doesn't often work for others, sadly.. If you get support on the horn that's the first thing they try. So it begs to question - maybe not use IE API to activate your product when IE is really not good, secure, or around much longer?

Norton is sloppy.