SECURITY: Complete oldschool's 2020 laptop setup

Last updated
Dec 12, 2020
About
Personal, primary device
Desktop OS
Windows 10
Login security
    • Password (Aa-Zz, 0-9, Symbols)
Primary sign-in
Local account
Primary user
Standard user - Limited permissions
Security updates
Automatic - allow all types of updates
Windows UAC
Maximum - always notify
Real-time protection
AVG Internet Security v. 20.10.3157
Software firewall
Microsoft Defender Firewall
Custom RTP, Firewall and OS settings
Default settings + Hardened Mode
Malware testing
No malware samples
Periodic security scanners
Hitman Pro (paid)
Browsers, Search and Addons
Brave/Brave Nightly --> Brave Shields + ClearURLs + LocalCDN
Edge Chromium --> Strict Tracking Protection + ClearURLs + LocalCDN
Maintenance and Cleaning
Windows built-in
Personal Files & Photos backup
Copy/Paste --> Free Agent drive
Personal backup routine
Device recovery & backup
Aomei Backupper Pro --> image monthly or as needed
System protection --> restore points as needed @ app or data changes
Device backup routine
PC activity
  1. Browsing the web. 
  2. Browsing to unknown sites. 
  3. Working from home. 
  4. Multimedia. 
  5. Streaming. 
Computer specs
Lenovo L340 i3 8145U CPU @ 2.10 GHz 2.300 GHz 8GB DDR4 RAM 1 TB HDD
Personal changelog
5/3/20 --> Removed Bitdefender and back to Windows Defender --> Updated RunBySmartscreen
May 2020 ---> various small changes
3 June, 2020 --> updated to W10 2004
7 June 2020 --> rolled back to 1909
23 August 2020 --> Added LocalCDN to browsers
27 August 2020 --> Removed µBO in Edge
31 August 2020 --> Removed Bitdefender Free
--------------------> Reverted to Windows Defender
--------------------> Removed Trafficlight and added Malwarbytes Browser Guard
7 September 2020 --> Removed Malwarebytes Browser Guard
Later in September --> Enabled Google SafeBrowsing in Brave

oldschool

Level 62
Verified
Mar 29, 2018
5,141
What's your initial impression?
Good performance and protection, fast scans, On/Off switch for HTTPS scanning.
and why did you choose AVG?
It's @McMcbrad 's fault. :LOL: Plus, I have a soft spot for AVG.:love:
 
F

ForgottenSeer 89360

That’s weird. Maybe the issue is related to network scanner? I do not know. I am not using AVG on my main device now, so I can not check whether the issue is fixed or not. Maybe it was a temporary fix for the activation issue. Regarding the issue you are having with the GUI, I had it months ago and was able to fix it by running a programme repair. I do confirm the second bug regarding showing the latest update. Anyway, in my experience with AVG, it is better and safer to download the offline installer.
You need to disable fake websites shield

1606585513138.png


This is not related to phishing, as this phishing is blocked by webshield,. This alters your DNS settings to prevent redirection to fake websites, when you type a real one.
 
Last edited by a moderator:

Pat MacKnife

Level 12
Verified
Jul 14, 2015
559
Its not the best version of AVG , installed it twice and it was always delayed detection when i tested @amtso test
warnings detections came after one minute... tested the same thing with avast and all was good (strange almost the same product, but it behaves different)
But i'm not an avast fan.... but i might give it another spin lol.
Installed KSC free yesterday and this works better than previous builds ( i guess they fixed several bugs) (y)
 
Last edited:
F

ForgottenSeer 89360

Its not the best version of AVG , installed it twice and it was always delayed detection when i tested @amtso test
warnings detections came after one minute... tested the same thing with avast and all was good (strange almost the same product, but it behaves different)
But i'm not an avast fan lol.
Installed KSC free yesterday and this works better than previous builds ( i guess they fixed several bugs) (y)
Hi, maybe it's been a temporary bug.
You can see there is no such behaviour (now at least) in the video I shared.
 
F

ForgottenSeer 89360

Ok thanks that is possible , but it was not funny that it didn't detect and warnings came very late....
Regarding the AMTSO tools, the drive-by test doesn't seem to work, maybe it has been designed to exploit behaviour that is now blocked in browsers. Everything else triggered instant notification on my test just now.
Cloud lookups test doesn't work either, it's supposed to download a file, but it doesn't download anything.

Update: Cloud lookups test works in Edge, but not in Chrome. Same is with the drive-by test.

1606586697940.png
1606586762307.png


On this window you can see it blocks the file so quick, it couldn't even be copied from the cache.
1606586878264.png
 
Last edited by a moderator:

oldschool

Level 62
Verified
Mar 29, 2018
5,141
it was always delayed detection when i tested @amtso test
I got some delayed detection
Regarding the AMTSO tools, the drive-by test doesn't seem to work, maybe it has been designed to exploit behaviour that is now blocked in browsers. Everything else triggered instant notification on my test just now.
Cloud lookups test doesn't work either, it's supposed to download a file, but it doesn't download anything.

Update: Cloud lookups test works in Edge, but not in Chrome. Same is with the drive-by test.

View attachment 249935View attachment 249936
I had mixed results in Brave, but it mostly worked. Brave handled a couple upon "Save".
None of this bothers me. I'm happy just the same.

@Pat MacKnife We are like kids in the sandbox! :D
 
F

ForgottenSeer 89360

Are you AVG guys aware of the geek area settings?
You open "settings" and in the search bar you type geek:area (similar to chrome:flags)
You'll see many advanced settings. I am not sure if I mentioned that in my review.

It works on Avast as well.

1606588017892.png
 

Divine_Barakah

Level 27
Verified
May 10, 2019
1,616
You need to disable fake websites shield

View attachment 249932

This is not related to phishing, as this is blocked by webshield, it alters your DNS settings to prevent redirection to fake websites, when you type a real one.
Thank you for your advice. Do you know anything about Active DNS?

Edit
My router is managed by my ISP and they give me user permissions and not admin one, so I cannot change the DNS in my router’s settings. If I change the DNS in the router settings, will it get changed by AVG?
 

oldschool

Level 62
Verified
Mar 29, 2018
5,141
As much as I like AVG, my trial has been discontinued due to web browsing issues. I tried it with HTTPS and QUIC/HTTP3 scanning off. Too many delays and timeouts.

I honestly don't remember having these issues in the past.

Microsoft Defender just works.
 
F

ForgottenSeer 89360

I also have everything enabled and have no issues.
I have been testing Avast and now AVG for months now.

I have also installed AVG on a low-end system that was protected by McAfee and the way I have configured it, it works better than before, with McAfee installed.
 
Last edited by a moderator:
Top