Q&A Should I allow this from Windscribe VPN v2.02 Build 10?

SumTingWong

Level 26
Verified
Apr 2, 2018
1,512
So I just upgraded my Windscribe VPN from v1.83 Build 20 to V2.02 Build 10, and I see this when I want to use it from ESET. Should I allow it or not? I can't use vpn unless I am allow it.
egui_dT25ldlBjw.png
 
Top