The Cog in the Machine

Level 23
Verified
List of current issues
My secondary HDD keeps turning off neglecting power plan settings
Steps taken, but have been unsuccessful?
Changed power plan settings to "never"
Hello! I have just connect a secondary HDD in my HP Desktop 290 G1 running Windows 10 Professional 2004 64-bit. The HDD keeps turning off (I can hear it when it turn off) but starts spinning again when I access a file store there. I do not want it to stop spinning as there is no need to save power. My main drive is Samsung Evo SSD. I have changed the setting in power plan and sat the option of "turn of HDD" to never but that did not work. Had a look at my desktop's BIOS and found nothing relevant. What should I do?
 
Last edited:

Digerati

Level 7
Verified
Why is this a problem? Is it staying off? It "should" spin up again when the computer is woken up and you start using the computer. Is it doing that?

Or are you saying it is turning off when you are using the computer?

And are you sure you are hearing the drive turning off and not a cooling fan?

And sadly, you didn't tell us which OS and version OS you are using.
 
Upvote 0

The Cog in the Machine

Level 23
Verified
Why is this a problem? Is it staying off? It "should" spin up again when the computer is woken up and you start using the computer. Is it doing that?

Or are you saying it is turning off when you are using the computer?

And are you sure you are hearing the drive turning off and not a cooling fan?

And sadly, you didn't tell us which OS and version OS you are using.
Hello and thank you for your fast reply. I have edited my post. No it does not stay off but I do not want it to turn off at all. It spins up again when I access files store there but is there any way to stop it from turning off? And yes I am sure it is the HDD not the cooling fan.
 
Upvote 0

The Cog in the Machine

Level 23
Verified
Hello,
If i remember this right, Process Lasso does have its own power profiles which you can tweak.
Damn good software, but it caused some lags on my system, so i uninstalled it.

Kind regards,
-sepik
Thank you for the great suggestion but I am not a fan of running such optimisation tools. Also, it does not make sense to install a programme for the sake of this problem which I believe can be fixed by other means.
 
  • Like
Reactions: upnorth
Upvote 0

Digerati

Level 7
Verified
I do not want it to stop spinning as there is no need to save power.
Well, saving power is only part of it. It is also about keeping heat down and minimizing wear and tear on the drive motor.

What is the brand and model number of the drive? It is important to note that many drives are "green" and it is coded in the drive's firmware to spin down when not being accessed. This is independent of the Power Options settings in Windows because the drive is NOT powering off - it is just slowing down its rotation speed when the system (and you) go idle.

If you CAREFULLY remove the drive from its bay and hold it in your hand (avoiding touching the electrical contacts of the logic board), you should still be able to feel it spinning when you think it is powered off. You could try just holding your finger on the drive when it is still mounted in the bay, but it might be difficult to determine if any vibration is coming from the drive, or from elsewhere and just being carried through the case and mounting screws to the drive. Isolating it in your hands ensures you are not feeling vibrations from another motor.

FTR, I agree with you about not using Process Lasso. There is nothing your problem description to indicate this is caused by Microsoft bungling process management. Contrary to what many seem to think, the developers at MS are pretty sharp and have learned a lot since the days of XP. This is especially true with W10. W10 is not XP - its time to stop treating it like it is.
 
Upvote 0

sepik

Level 9
I think some HDD manufacturers does have "hard coded" the "sleep" mode. Not sure tho, one way might be to use manufacturer own tools to enable/disable spin down.
 
Upvote 0

TairikuOkami

Level 28
Verified
Content Creator
I have changed the setting in power plan and sat the option of "turn of HDD" to never but that did not work.
I had the same annoying issue, try to enforce it via policy.
Code:
reg add "HKLM\Software\Policies\Microsoft\Power\PowerSettings\E69653CA-CF7F-4F05-AA73-CB833FA90AD4" /v "DCSettingIndex" /t REG_DWORD /d "0" /f
reg add "HKLM\Software\Policies\Microsoft\Power\PowerSettings\6738E2C4-E8A5-4A42-B16A-E040E769756E" /v "ACSettingIndex" /t REG_DWORD /d "0" /f
 
Last edited:
Upvote 0

The Cog in the Machine

Level 23
Verified
I had the same annoying issue, try to enforce it via policy.
Code:
reg add "HKLM\Software\Policies\Microsoft\Power\PowerSettings\E69653CA-CF7F-4F05-AA73-CB833FA90AD4" /v "DCSettingIndex" /t REG_DWORD /d "0" /f
Thank you my friend. Unfortunately I tried that with no success and just forgot to mention that in my original post. But thank you for your help. Did it work for you?

Update:
I am sorry I was confused by the method of trying to edit power plans using CMD and the method you suggested. Could you please elaborate more on how to do it?
 
Upvote 0

sepik

Level 9
Yeah, the OS can make it "sleep" in some situations. If OS power schemes modifications does not work, the problem might be elsewhere. An AV? Other softwares installed etc. My D:\ HDD goes to "sleep" when there's no activity, why it should be "awake" all the time afterall?.
BUT, i ran Steam from my D:\ HDD. And Steam writes bytes or two when idle, and OS/av does that too. However, when i start the game, i hear the sound when my HDD "spins up".
 
  • Like
Reactions: roger_m
Upvote 0

Digerati

Level 7
Verified
Well I don't see anything in the product's documentation indicating it is a green or that it has an Eco mode. But it does show 2 different power consumption figures, one for Read / Write and one for Idle. But not sure that has anything to do with this.

I do think, however, you need to verify it really is turning off and not just slowing down to an inaudible rotation speed.
 
  • Like
Reactions: roger_m and upnorth
Upvote 0

Digerati

Level 7
Verified
You can tell, you will get like 1-2 secs lag in the explorer, while it waits for it to start.
That does not mean it is turning off. That just means the rotation speed has slowed down. There's a difference. If the drive is off, it has to reinitialize and that typically takes longer than 1 or 2 seconds.
 
Upvote 0
Top