Aerdian

Level 3
Verified
Hello! I recently built a new computer and was attempting to install some operating systems in VMWare Workstation Player 14. However, it stated that my host supports AMD-V, but it is disabled. I had already gone into my BIOS and enabled IOMMU, which is (unless I'm incorrect) the virtualization technology for Ryzen. I tried VirtualBox and it had a similar problem. It didn't let me pick 64-bit in the first place and, after creating a VM, it wouldn't boot. It didn't give me any reasons why it wouldn't boot, though. It doesn't seem to have anything to do with the OS, since I tried Windows and several different Linux distros.

Thanks for the help!

CPU: AMD Ryzen 7 2700X
Motherboard: Gigabyte X470 Aorus Ultra Gaming
 

Aerdian

Level 3
Verified
Have you checked the logs in VirtualBox? Machine/Show Log or Ctrl+L

Hopefully can help you trace the issue. Check the logs right after you tried boot the VM.
Sorry for the late reply. I wasn't able to use my computer yesterday. Anyways, this is what VirtualBox says after the VM crashes immediately after starting it:

AMD-V is disabled in the BIOS (or by the host OS) (VERR_SVM_DISABLED).

Result Code:
E_FAIL (0x80004005)
Component:
ConsoleWrap
Interface:
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

VMWare:
This host supports AMD-V, but AMD-V is disabled. AMD-V might be disabled if it has been disabled in the BIOS/firmware settings or the host has not been power-cycled since changing this setting. (1) Verify that the BIOS/firmware settings enable AMD-V. (2) Power-cycle the host if this BIOS/firmware setting has been changed. (3) Power-cycle the host if you have not done so since installing VMware Player. (4) Update the host's BIOS/firmware to the latest version. This host does not support "AMD RVI" hardware assisted MMU virtualization. Module 'CPUIDEarly' power on failed. Failed to start the virtual machine.

And this is the log for VirtualBox:
00:00:01.499803 ********************* End of CFGM dump **********************

00:00:01.499839 VM: fHMEnabled=true (configured) fRecompileUser=false fRecompileSupervisor=false

00:00:01.499841 VM: fRawRing1Enabled=false CSAM=true PATM=true

00:00:01.500038 VMSetError: F:\tinderbox\win-5.2\src\VBox\VMM\VMMR3\HM.cpp(736) int __cdecl HMR3Init(struct VM *); rc=VERR_SVM_DISABLED

00:00:01.500082 VMSetError: AMD-V is disabled in the BIOS (or by the host OS)

00:00:01.500780 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={872da645-4a9b-1727-bee2-5585105b9eed} aComponent={ConsoleWrap} aText={AMD-V is disabled in the BIOS (or by the host OS) (VERR_SVM_DISABLED)}, preserve=false aResultDetail=0

00:00:01.501116 Console: Machine state changed to 'PoweredOff'

00:00:01.507489 Power up failed (vrc=VERR_SVM_DISABLED, rc=E_FAIL (0X80004005))

00:00:02.007291 GUI: UIMachineViewNormal::resendSizeHint: Restoring guest size-hint for screen 0 to 800x600

00:00:02.007332 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={76eed314-3c72-4bbb-95cf-5eb4947a4041} aComponent={DisplayWrap} aText={The console is not powered up}, preserve=false aResultDetail=0

00:00:02.007451 GUI: Aborting startup due to power up progress issue detected...
 

Aerdian

Level 3
Verified
  • Like
Reactions: BryanB and upnorth