Q&A vmware workstation 12 W7 aero lag

Discussion in 'Rollback and Virtualisation' started by Skinoku, Feb 8, 2016.

  1. Skinoku

    Skinoku Level 1

    Dec 11, 2015
    34
    38
    Technician
    Italy
    Windows 10
    ESET
    Hi everyone!
    I'm using vmware workstation 12.1 pro on my computer (i7 6700k 4GHz, 16gb RAM, nvidia 970) with Windows 10 pro latest build. (10.0.10586.71) 64bit as host OS.
    When I try running Win 7 pro 64bit in a vm and enable Aero effects, dragging or minimizing windows becomes very slow and lags. With default windows 7 basic theme all works fine.
    I think it's not a lack of resources, infact windows 7 guest performance index is 7 over 7.9.
    It looks strange because on my old macbook pro using vmware fusion 8 pro that is A LOT less powerful it runs smoot as a charm!
    Thanks in advance!
     
  2. illumination

    illumination Guest

    How much resources did you allocate to the guest, and do you have VMware tools installed?
     
  3. safe1st

    safe1st Level 16

    Jan 29, 2016
    787
    7,092
    Unknown
    Windows 10
    Zemana
    Yup, you're right @illumination
    He should install VMware tools first. After that, no lag at all
     
    Jrs30 and Skinoku like this.
  4. Skinoku

    Skinoku Level 1

    Dec 11, 2015
    34
    38
    Technician
    Italy
    Windows 10
    ESET
    Of course, Vmware tools are propely installed, with 4gb of dedicated ram and 4 CPU threads!
     
  5. illumination

    illumination Guest

    That guest should be flying and smooth. I'm assuming all updates are installed for W7 then? If so do you have another copy of W7 laying around to install another guest and try to reproduce the problem?
     
    Skinoku likes this.
  6. Vasudev

    Vasudev Level 22

    Nov 8, 2014
    1,109
    2,185
    Student
    India
    Windows 10
    Microsoft
    Enable VT-x in UEFI/BIOS and tick vitualize all counters in VM Workstation.
     
    Skinoku likes this.
  7. Skinoku

    Skinoku Level 1

    Dec 11, 2015
    34
    38
    Technician
    Italy
    Windows 10
    ESET
    Thank you @Vasudev!
    Virtualization was already enabled in my UEFI bios, I just ticked "Enable VT-x" and "Virtualize counters" in the VM configuration panel under CPU options.
    Almost all the lag disappeared!
     
    Vasudev likes this.
  8. Soulweave

    Soulweave Moderator
    Staff Member Content Creator

    Jan 14, 2015
    1,360
    3,395
    Windows 10
    Kaspersky
    Enable VT-x is usually disabled on mine, but I do not run W7 on VM, so couldnt help you there. Without VT-x ticked, 8.1 and 10 work fine hardly any lag. I did however modify the windows installations to near barebones, breaking a few in the process, etc. but that is beside the point.
     
    Skinoku and illumination like this.
  9. jamescv7

    jamescv7 Level 61
    Trusted

    Mar 15, 2011
    12,664
    17,722
    Web and FileMaker Developer
    Philippines
    Windows 10
    Microsoft
    Usually you need to double check the VMWare tools that pertains to provide acceleration and performance although not practical when its all about testing.
     
    Skinoku likes this.
  10. scotland1

    scotland1 New Member

    Sep 21, 2017
    1
    2
    Spain
    Windows 8.1
    I had the same problem with HUGE lags when aero is active on Dell 7510 (1575 xeon, 64gb RAM, 2gb of m2.ssd) that I bought over $5000 (jan 2017). I have two video cards on board - Nvidia Quadro M2000M and Intell. I guess Dell have problem with laptops that contain two video cards and vmware doesn't support it properly.

    Solution that helped me is very simple and fast - just downgrade from 12.x to 10.x hardware compatibility (VM->Manage->Change Hardware Compatibility).
     
    Vasudev and Sunshine-boy like this.
Loading...
Similar Threads Forum Date
Update VMware Workstation 14.1.1 Build 7528167 Rollback and Virtualisation Jan 9, 2018
Update VMware Workstation 14.1 Build 7370693 Rollback and Virtualisation Dec 22, 2017
Q&A ShadowDefender and Vmware Workstation General Security Discussions Oct 7, 2017