Advice Request YouTube video delay

Please provide comments and solutions that are helpful to the author of this topic.

Cleo

Level 6
Thread author
Verified
Well-known
May 25, 2020
271
Hi MT.
I have developed a weird glitch in my browser while on YouTube.
If I have ANY extension installed then every video will have the video feed buffer for 5-7s before starting. The audio starts immediately so they are out of sync.
This is also happening in my Opera browser. I have adguard using my nextdns service via https.
System: Win 11 Intel system with Avast Premium. My usual extensions are protonpass, mailvelope and adguard. Disabling them all removes the issue but enabling any
restores the issue. It occurs irrespective of drivers, vpn connection, cache cleared.
I have CPU boosting disabled in BIOS. (The base clock rate is 2.3 and the boost is 4.6. My cpu fan can't cope with a curve like that. Sounds like a jet engine every time i do anything)
Resetting Edge clears it until I add an extension.
Any ideas?
 
  • Like
Reactions: Nevi and Jack

Bot

AI-powered Bot
Verified
Apr 21, 2016
3,125
Hi there!

It seems like you're experiencing a specific issue with YouTube videos buffering for a few seconds before starting, and the audio being out of sync when you have any extension installed in your Microsoft Edge or Opera browser. This problem occurs regardless of your drivers, VPN connection, or cleared cache. Additionally, disabling all extensions resolves the issue, but enabling any of them brings it back.

Based on the information you provided, it's possible that one of your installed extensions is causing the problem. To troubleshoot this, I would suggest the following steps:

1. Disable all extensions: Start by disabling all of your extensions in Microsoft Edge or Opera. This will help determine if the issue is caused by a specific extension or a combination of them.

2. Enable extensions one by one: After disabling all extensions, enable them one by one and test YouTube videos after enabling each one. This will help identify which extension is causing the buffering and audio sync issue.

3. Update or remove problematic extensions: If you find that a specific extension is causing the problem, check for updates for that extension. If an update is available, install it and test YouTube again. If the issue persists, you may consider removing the problematic extension or reaching out to the extension developer for further assistance.

4. Check for browser updates: Ensure that you have the latest version of Microsoft Edge or Opera installed. Sometimes, updating the browser can resolve compatibility issues with extensions.

5. Try using an alternative browser: If the issue persists, you can try using a different browser, such as Google Chrome or Mozilla Firefox, to see if the problem occurs there as well. This will help determine if the issue is specific to Microsoft Edge and Opera or if it's a more general problem.

6. Contact extension developers or browser support: If none of the above steps resolve the issue, you may need to reach out to the extension developers for further assistance. Additionally, you can contact the support teams for Microsoft Edge or Opera, providing them with detailed information about your issue, including the extensions you have installed and the steps you have already taken to troubleshoot the problem.

I hope these steps help you identify and resolve the issue with YouTube videos buffering and audio sync. Let me know if you have any further questions or need additional assistance!
 
  • Like
Reactions: vtqhtr413 and Jack

partha_roy

Level 3
Well-known
Oct 16, 2022
110
I came across this article at that may explain why

If you are fine with the yt ads, you may disable the adguard on yt and check if the issue occurs or try using Adblock Plus; it works great for me
 
  • Like
Reactions: Jack, Cleo and Nevi

Cleo

Level 6
Thread author
Verified
Well-known
May 25, 2020
271
I came across this article at that may explain why

If you are fine with the yt ads, you may disable the adguard on yt and check if the issue occurs or try using Adblock Plus; it works great for me
I have premium YouTube and AdGuard is disabled on youtube.com. The problem persists if ANY extension is enabled. I will test whitelisting youtube.com in my pc's nextdns profile.Or even just switch my DNS to Google.
 
  • Like
Reactions: Jack and Nevi

About us

  • MalwareTips is a community-driven platform providing the latest information and resources on malware and cyber threats. Our team of experienced professionals and passionate volunteers work to keep the internet safe and secure. We provide accurate, up-to-date information and strive to build a strong and supportive community dedicated to cybersecurity.

User Menu

Follow us

Follow us on Facebook or Twitter to know first about the latest cybersecurity incidents and malware threats.

Top