Bravo F-secure! (Winner of AV-C Performance Test October 2020)

upnorth

Moderator
Verified
Staff member
Malware Hunter
Jul 27, 2015
4,176
Looks like a bug of the removal engine.
Very possible, but also hard to fully investigate as you already uninstalled and can't send any support tool report. If you still have the samples, you can always contribute anyway and help with this possible " bug ". Either send me the hash or submit the samples directly to F-Secure.
 

SeriousHoax

Level 34
Verified
Mar 16, 2019
2,391
Very possible, but also hard to fully investigate as you already uninstalled and can't send any support tool report. If you still have the samples, you can always contribute anyway and help with this possible " bug ". Either send me the hash or submit the samples directly to F-Secure.
I can send you the files in PM if you want to check whether you can reproduce the same bug in your system.
 

upnorth

Moderator
Verified
Staff member
Malware Hunter
Jul 27, 2015
4,176
Followed your instructions and just as you said, F-Secure did delete the file as soon I accessed the folder where I saved it. But, I was very able to not just restore the file, but also exclude it. Simply went to quarantine, and clicked Allowed and F-Secure asked if I really wanted to exclude the file and also allow it to be executed. It was of course not automatic executed/run but when or if I wanted. Refreshed the page where I had the folder and, Voilà the file was back.
 

SeriousHoax

Level 34
Verified
Mar 16, 2019
2,391
Followed your instructions and just as you said, F-Secure did delete the file as soon I accessed the folder where I saved it. But, I was very able to not just restore the file, but also exclude it. Simply went to quarantine, and clicked Allowed and F-Secure asked if I really wanted to exclude the file and also allow it to be executed. It was of course not automatic executed/run but when or if I wanted. Refreshed the page where I had the folder and, Voilà the file was back.
It's a random bug then. Not reproducible every time. Did F-Secure asked for system restart?
 
  • Like
Reactions: upnorth

upnorth

Moderator
Verified
Staff member
Malware Hunter
Jul 27, 2015
4,176
It's a random bug then. Not reproducible every time. Did F-Secure asked for system restart?
Nope it didn't and that is not something I personal see or recall much on my own system. Still, it was a interesting test. I'll see if I can find any more information about this possible bug on their forum as normally when it's a general bug, those get report a lot.
 

SeriousHoax

Level 34
Verified
Mar 16, 2019
2,391
Nope it didn't and that is not something I personal see or recall much on my own system. Still, it was a interesting test. I'll see if I can find any more information about this possible bug on their forum as normally when it's a general bug, those get report a lot.
The other one was related to sandboxie driver which was already installed on the system. Since it's a driver with a process that was already running, it probably caused F-Secure to ask for system restart. Then the sample I pointed you out was also detected. So I think you have check the other one to see if the bug happens.
 

upnorth

Moderator
Verified
Staff member
Malware Hunter
Jul 27, 2015
4,176
The other one was related to sandboxie driver which was already installed on the system. Since it's a driver with a process that was already running, it probably caused F-Secure to ask for system restart. Then the sample I pointed you out was also detected. So I think you have check the other one to see if the bug happens.
Nah, I'm fine and satisfied enough and as I said, I will check their forum. Thanks anyway. (y)
 

upnorth

Moderator
Verified
Staff member
Malware Hunter
Jul 27, 2015
4,176
A small tip! F-Secure even got an official channel for bug reports, except their support.

Almost forgot one thing! @SeriousHoax , about your upcoming bug test. Create a new thread instead. Point to this with a link if you like.
 
Top