1. Tairan

    Tairan Level 3

    Oct 1, 2016
    125
    357
    Dayton, OH
    With the KIS 18 version, I cannot install the certificate (Encrypted Connections Advanced Settings) and therefore keep getting the "Cannot guarantee authenticity of the domain to which encrypted connection is established" message.

    This is very annoying, please help!
     
  2. v.maroz

    v.maroz Level 1

    Aug 20, 2017
    4
    12
    Belarus
    Windows 10
    Kaspersky
    Install the certificate Kaspersky Lab. manually into the browser.
    1) For Google Chrome
    To do this, locate the certificate on the computer by c: \ ProgramData \ Kaspersky \ AVP18.0.0 \ Data \ Cert \ (fake) Kaspersky Anti-Virus Personal Root Certificate.cer, and then in the Settings -> Advanced settings, in the HTTPS section / SSL, click the Configure Certificates button.
    To install the certificate, click on the "Trusted Root Certification Authorities" tab and click the "Import ..." button
    2) For Mozilla Firefox
    In the Mozilla Firefox menu (at the top right - three horizontal lines) click "Settings - Additional - View certificates - Certification authorities". Then click "Import", in the opened window select the file "C: \ ProgramData \ Kaspersky Lab \ AVP18.0.0 \ Data \ Cert \ (fake) Kaspersky Anti-Virus Personal Root Certificate.cer). Install it by checking the "Trust when checking sites" checkbox.
     
    harlan4096 likes this.
  3. motox781

    motox781 Level 5

    Apr 1, 2015
    242
    749
    USA
    Windows 10
    Kaspersky
    #3 motox781, Sep 9, 2017
    Last edited: Sep 9, 2017
    I tried the above, but still get the message: "Cannot guarantee authenticity of the domain to which encrypted connection is established" on 3 different Windows 10 PCs running KIS 18.0.0.45(c) and Google Chrome.

    Any other ideas?

    @harlan4096
     
  4. Warrior

    Warrior Level 4

    Sep 2, 2014
    174
    337
    retired
    Scotland
    been there done all that , same issue , uninstalled Kaspersky :)
     
  5. motox781

    motox781 Level 5

    Apr 1, 2015
    242
    749
    USA
    Windows 10
    Kaspersky
    I feel you. I have been fighting with this for awhile now. Everything else works fine, but this. Happened in 2017 also. Bad thing is, I just bought a 3 year license. Anyway, it may be related to Chrome.
     
  6. Dhruv2193

    Dhruv2193 Level 3

    Nov 7, 2016
    52
    175
    India
    Windows 10
    Emsisoft
    I was also facing the same issue. Tried everything but did not go away. Then I added an exclusion in web antivirus protection component for the websites in addition to the encrypted connections option. For 1 day the message did not come. just hope it doesn't come again.
     
    XhenEd likes this.
  7. Paul.R

    Paul.R Level 6

    May 16, 2013
    406
    293
    hi!

    I had on my mac some problems with certifcates but there were from my antivirus, kaspersky.
    Solution:
    - uninstall kaspersky
    - uninstall firefox(if you had installed first)
    - restart if asking
    - install firefox
    - install kaspersky

    All good after this.
     
    harlan4096 likes this.
Loading...