New Update NordVPN 8.10.1 requires iOS 14.2 or newer; drops IKEv2 protocol

Ink

Administrator
Thread author
Verified
Staff Member
Jan 8, 2011
22,490

NordVPN 8.10.1​

  • From now on, the minimum iOS version required for the NordVPN app is 14.2. We’re dropping support for earlier versions because they don’t allow us to ensure top-grade security.
  • The IKEv2 protocol is no longer available in our app. It’s been a good run, but we want to offer you only the best cybersecurity solutions. For both speed and security, we recommend using the NordLynx protocol.
  • We’ve added a new setting that will let you keep your device invisible on the local network when connected to a VPN. While invisible, you won’t be able to access other network devices, such as computers, printers, or TVs. This setting prevents potential VPN traffic leaks caused by operating system limitations.

 

About us

  • MalwareTips is a community-driven platform providing the latest information and resources on malware and cyber threats. Our team of experienced professionals and passionate volunteers work to keep the internet safe and secure. We provide accurate, up-to-date information and strive to build a strong and supportive community dedicated to cybersecurity.

User Menu

Follow us

Follow us on Facebook or Twitter to know first about the latest cybersecurity incidents and malware threats.

Top