Bundled with PUP
None

Dhruv2193

Level 5
Verified
Joined
Nov 7, 2016
Messages
202
Operating System
Windows 10
Antivirus
Emsisoft
#1
I wanted to know is enabling encrypted connections scanning necessary for being protected against malicious webpages and phishing sites? Ihave read on many sites but cannot zero in on the answer.
 
Likes: harlan4096

harlan4096

Moderator
MalwareTips Team
AV-Tester
Verified
Joined
Apr 28, 2015
Messages
3,967
Operating System
Windows 10
Antivirus
Kaspersky
#2
Disabling it, as it said in the warning popup/contextual help of the product may reduce the functionality of some features/modules, but still Kaspersky is protecting You at traffic level...
 
Joined
May 8, 2018
Messages
144
Operating System
Windows 10
Antivirus
Kaspersky
#3
for me, disabling encrypted connections in kaspersky will disable web protection (will not work against known malicious websites/phishings) too.
 
Likes: Dhruv2193

Dhruv2193

Level 5
Verified
Joined
Nov 7, 2016
Messages
202
Operating System
Windows 10
Antivirus
Emsisoft
#4
Disabling it, as it said in the warning popup/contextual help of the product may reduce the functionality of some features/modules, but still Kaspersky is protecting You at traffic level...
Thanks, so if one disables encrypted scanning, kaspersky should still warn about malicious web pages?
 

harlan4096

Moderator
MalwareTips Team
AV-Tester
Verified
Joined
Apr 28, 2015
Messages
3,967
Operating System
Windows 10
Antivirus
Kaspersky
#6
If You disable "Scan Encrypted connections upon request", it will only detect http but not https... just tried EICAR Test, the links/files with https were not detected by WebAV but the files were detected/deleted by FileAV once they were downloaded...

Anyway, I don't see the general point in disable this feature, if You are having issues with Chrome or FF (I am with this forum some times) about TLS 1.3, just add this URL to NetWork -> Encrypted connections scanning -> Manage exclusions... temporally until the issue is fixed...
 

Gandalf_The_Grey

Level 10
Verified
Joined
Apr 24, 2016
Messages
490
Operating System
Windows 10
Antivirus
Kaspersky
#8
If You disable "Scan Encrypted connections upon request", it will only detect http but not https... just tried EICAR Test, the links/files with https were not detected by WebAV but the files were detected/deleted by FileAV once they were downloaded...

Anyway, I don't see the general point in disable this feature, if You are having issues with Chrome or FF (I am with this forum some times) about TLS 1.3, just add this URL to NetWork -> Encrypted connections scanning -> Manage exclusions... temporally until the issue is fixed...
I just disabled TLS 1.3 in Chrome Flags and (almost) no more problems with Chrome and KFA. Is that not a better solution than whitelisting sites?
 
Last edited:
Likes: harlan4096

harlan4096

Moderator
MalwareTips Team
AV-Tester
Verified
Joined
Apr 28, 2015
Messages
3,967
Operating System
Windows 10
Antivirus
Kaspersky
#9
As I said, that is a temporal workaround... if You disable TLS 1.3, this will affect to all the sites, those where You are having issues with TLS 1.3 and those where not... whitelisting only the URL/sites with issues allows You to still keep TLS 1.3 in general...
 

Gandalf_The_Grey

Level 10
Verified
Joined
Apr 24, 2016
Messages
490
Operating System
Windows 10
Antivirus
Kaspersky
#10
As I said, that is a temporal workaround... if You disable TLS 1.3, this will affect to all the sites, those where You are having issues with TLS 1.3 and those where not... whitelisting only the URL/sites with issues allows You to still keep TLS 1.3 in general...
Of course you're right.
In my case with a shared family computer it was easier to disable TLS 1.3 till the issues are fixed.
Family members can't whitelist sites.
But I will enable TLS 1.3 again in Chrome.
They can ask me to whitelist a site or use Edge that has no problems with KFA.
I don't know if Edge supports TLS 1.3 yet...
 
Likes: harlan4096

Dhruv2193

Level 5
Verified
Joined
Nov 7, 2016
Messages
202
Operating System
Windows 10
Antivirus
Emsisoft
#11
harlan4096, i am runnign KIS2019 with patch a and have 1 problem- when i enable encrypted connections scanning, and type something in the address bar of chrome, the google page result does not come but when i disable it, the result comes. In case it is enabled, i have to first go to google.com and then type any search query and then the results come.
 

harlan4096

Moderator
MalwareTips Team
AV-Tester
Verified
Joined
Apr 28, 2015
Messages
3,967
Operating System
Windows 10
Antivirus
Kaspersky
#12
@Dhruv2193: I can't reproduce that issue now, I'm in my lap for summer season, don't have access to my virtual machines, and in this system I'm testing KTS2020 .318... I can't reproduce that issue with Chrome here with KTS2020, I have Scan encrypted connections upon request (default setting)...

Check if You have more than 1 "Kaspersky Root Certificate" installed in Windows Certificate repository... you should have only 1 and the most updated belonging to Your current Kaspersky product version.
 

yitworths

Level 10
Verified
Joined
May 31, 2015
Messages
470
Operating System
Windows 10
Antivirus
Kaspersky
#13
harlan4096, i am runnign KIS2019 with patch a and have 1 problem- when i enable encrypted connections scanning, and type something in the address bar of chrome, the google page result does not come but when i disable it, the result comes. In case it is enabled, i have to first go to google.com and then type any search query and then the results come.
I'm also running patch a & like harlan4096 I'm also unable to re-produce that. You should re-check your settings & extensions.
 

Dhruv2193

Level 5
Verified
Joined
Nov 7, 2016
Messages
202
Operating System
Windows 10
Antivirus
Emsisoft
#14
Thanks harlan and yitworths, i un-installed the cert. from chrome and then imported from the kaspersky cert. folder and now no problem is there. UPDATE- the problem came back and i re-installed the extension of kaspersky and not faced the problem till now. Lets wait and see if it comes back.
 
Last edited:

RoboMan

Level 25
Content Creator
Verified
Joined
Jun 24, 2016
Messages
1,432
Operating System
Windows 10
Antivirus
#15
harlan4096, i am runnign KIS2019 with patch a and have 1 problem- when i enable encrypted connections scanning, and type something in the address bar of chrome, the google page result does not come but when i disable it, the result comes. In case it is enabled, i have to first go to google.com and then type any search query and then the results come.
Add google.com to URL exclusions?