SearchLight

Level 11
Verified
For weeks, I have been trying to enable Secure DNS over HTTPS in Microsoft Edge Stable. Although, I found how to enable the feature via the experimental flags accessed through the address bar, whenever I went to Cloudfare's help site: 1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolver , the response back was that it was not happening.

The current stable version of Edge has no Custom Settings for one's preferred DNS service, so I searched the web, and found that the customization feature is currently available in Microsoft Edge Canary. I downloaded Canary, and low and behold, I have Secure DNS over HTTPS using Cloudfare. I am using this as a backup browser but whenever I use it, I have encountered no hiccups just like Edge Stable.

Thus, if you are a Microsoft Edgeaphile, and looking for the feature now, you can find it in the Canary version.

I guess Microsoft doesn't stay as current with the latest features like Google Chrome, Firefox, and Opera do. I have these browsers as well, and Secure DNS over HTTPS is active, and working within them.
 
Last edited:

silversurfer

Level 66
Verified
Trusted
Content Creator
Malware Hunter
For weeks, I have been trying to enable Secure DNS over HTTPS in Microsoft Edge Stable. Although, I found how to enable the feature via the experimental flags accessed through the address bar, whenever I went to Cloudfare's help site: 1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolver , the response back was that it was not happening.
Here on my latest stable Edge, DoH by Cloudflare works properly after manually to enable this flag: "Secure DNS lookups"

1.png2.png3.png
 

silversurfer

Level 66
Verified
Trusted
Content Creator
Malware Hunter
For weeks, I have been trying to enable Secure DNS over HTTPS in Microsoft Edge Stable. Although, I found how to enable the feature via the experimental flags accessed through the address bar, whenever I went to Cloudfare's help site: 1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolver , the response back was that it was not happening.
Do you have ever tried to setup Cloudflare DNS on settings of Windows 10:
This could be the reason why my Edge (latest stable) works over DoH by Cloudflare