SumTingWong

Level 24
Verified
I have Firefox and Google Chrome with Ublock Origin and HTTPS Everywhere extensions and both browser extensions have the same settings, but for some reason Ublock Origin on Chrome only block 24 or 23% when I'm on Crunchyroll and the videos show ads compare to Firefox Ublock Origin blocked 40 or 29% and no ads in the video on Crunchyroll.

I have tried clear browser cache, cookies, and everything and I also reinstalled Ublock Origin and no luck. I also tried reinstall Chrome and no luck. What is going on? I was shocked when I see ads displayed in the video on Crunchyroll in Chrome with Ublock Origin.
 

Burrito

Level 23
Hmmmm.....seem like sum ting wong.

uBO is implemented differently in Chrome and Firefox sometimes.

Here is an example:

uBlock Origin performance improvements thanks to WASM (Firefox only, for now)
A recent version of the content blocking extension uBlock Origin uses WebAssembly (WASM) code to improve the performance of the extension.
The new uBlock Origin 1.17.4 is already available on the GitHub project website and Google and Mozilla web stores for extensions.
The new versions get pushed out to users in a rolled released which means that you may not get it immediately. Chrome and Firefox users may enforce the update. Chrome users may want to read how to update Chrome extensions manually for information on how that is done, Firefox users may check this guide instead.
Raymond Hill (gorhill) notes that the new code is only active in the Firefox extension and not in the extension for Google Chrome. The reason for that is that Google Chrome does not allow wasm "without adding 'unsafe-eval' to the extension's own Content Security Policy in its manifest" which Raymond considers unsafe for use).

To get to the specifics of your question.... you need an expert. Perhaps @Windows_Security or @Evjl's Rain or @oldschool or @Andy Ful..
 
Last edited:

oldschool

Level 54
Verified
@SumTingWong @Burrito - I never use Chrome & haven't used Firefox in quite awhile so I have no way to compare. I see that it's a subscription service so I can't check it with Edge Dev browser. I'd guess it's a browser issue but :unsure: :unsure::unsure::unsure:

@SumTingWong - Please re-post over at this thread: Discuss - uBlock Origin/Nano Adblocker - user tips, questions and issues thread You might get more help.

Edit: It might be cacheStorageAPI, or related to the disabled extension fixes Mozilla pushed. Be aware that not all users were/are affected and there user experiences with this issue may be different as well. Are you on Mozilla forum or reddit/firefox/ublock? I would check there and maybe at Wilders as a lot of their members use FF.
 
Last edited:

Burrito

Level 23
@SumTingWong @Burrito - I never use Chrome & haven't used Firefox in quite awhile so I have no way to compare. I see that it's a subscription service so I can't check it with Edge Dev browser. I'd guess it's a browser issue but :unsure: :unsure::unsure::unsure:
Oh yeah, I sorta knew that (..about you and Chrome & Firefox). I was just thinking of your newfound uBO Expert Status here at MT and forgot..

213403
 

Windows_Security

Level 23
Verified
Trusted
Content Creator
As explained by @Burrito to use the faster WebAssembly Google requires that an extension obtains eval () permission in the Content Security Policy of an extension. Raymond Hill does not want that because it is considered bad coding practice and a security liability. When you read this info on developer.mozilla.org it even states in bold :
developer.mozilla.org said:
Do not ever use eval!
Eval() is a dangerous function, which executes the code it's passed with the privileges of the caller. If you run eval() with a string that could be affected by a malicious party, you may end up running malicious code on the user's machine with the permissions of your webpage / extension.

So it has little use asking Raymond Hill to implement this as long as Google keeps this (seemingly stupid) requirement. As he explains here
Raymond Hill said:
I wish to be able to use WebAssembly from my extension -- this is already the case for the Firefox version of the extension. However, I do not plan to use wasm-unsafe-eval if/when it becomes available, as this goes against the spirit of not executing remote code.
 

Cauthern

New Member
@SumTingWong @Burrito - I never use Chrome & haven't used Firefox in quite awhile so I have no way to compare. I see that it's a subscription service so I can't check it with Edge Dev browser. I'd guess it's a browser issue but :unsure: :unsure::unsure::unsure:

@SumTingWong - Please re-post over at this thread: Discuss - uBlock Origin/Nano Adblocker - user tips, questions and issues thread You might get more help.

Edit: It might be cacheStorageAPI, or related to the disabled extension fixes Mozilla pushed. Be aware that not all users were/are affected and there user experiences with this issue may be different as well. Are you on Mozilla forum or reddit/firefox/ublock? I would check there and maybe at Wilders as a lot of their members use FF.
Can anyone tell me how to get in a lock computer

Can anyone tell me how to get in a lock computer
What do you mean? Did you forgot the password?
We got a call saying that we were due a refund. Wanting our bank account. When we didn't give it . Guy block our computer. Can't get pass the password.
 

Evjl's Rain

Level 45
Verified
Trusted
Content Creator
Malware Hunter
just watched a sample video on that site without any ad using chrome
are you sure you have exact same filters on both ublock? What filters do you have on chrome's ublock?
according to my observation, easylist/adguard english filters are not helpful on this site
adversity, stevenblack, 1hosts mini are the ones who blocked the most
 

harlan4096

Moderator
Verified
Staff member
Malware Hunter

SumTingWong

Level 24
Verified
just watched a sample video on that site without any ad using chrome
are you sure you have exact same filters on both ublock? What filters do you have on chrome's ublock?
according to my observation, easylist/adguard english filters are not helpful on this site
adversity, stevenblack, 1hosts mini are the ones who blocked the most
I have Easylist and Adguard English enabled in the past fine and no ads on Crunchyroll videos but now there are ads displayed in Crunchyroll videos. I tested the same filters and settings on my secondary Windows computer on Google Chrome latest and no ads displayed on Crunchyroll videos. Now I am confused why the heck my main PC Chrome allow ads but not on my secondary Windows PC with Chrome and same filters and settings as Firefox and no ads in Crunchyroll videos.

I am confused now like for real.
 

oldschool

Level 54
Verified
Test the filters and settings on my secondary machine and it blocked ads in Crunchyroll videos so I don't know what it is going on with my main rig.
Are your Chrome settings identical on both PCs? Have you cleaned your cache, etc. or tried a clean install of Chrome on your main rig? My gut tells me it's a browser issue but I have no logical basis for this.
 
Last edited:

SumTingWong

Level 24
Verified
Are your Chrome settings identical on both PCs? Have you cleaned your cache, etc. or tried a clean install of Chrome on your main rig? My gut tells me it's a browser issue but I have no logical basis for this.
Chrome settings sync with my Google account so yes browser settings identical on both PC. I already tried clear cache, etc, reinstall extension and browser and no luck.

I don't know anymore. I think my main rig decided to go hiccup mode or Chrome browser doesn't like my main rig at all?
 
Top