karthic1998

Level 4
Pre-moderated
Yes, I only block Malware + Ads & Trackers. Not Social Networks, this will be too much of any annoyance otherwise.
It also blocks social network annoyance mate if you have own premium account try it now
I impressed because it works amazing for me by blocking everything that I didn’t needed
 
  • Like
Reactions: DeepWeb

HarborFront

Level 46
Verified
Content Creator
I have one issue for its android version.

I set it to always-on for a day and somewhere in the later part of the day a message pops up saying Windscribe is consuming a lot of power behind the scene. I did the same for Avira Phantom Pro VPN but no such issue.
 

LDogg

Level 29
Verified
Is it me or normal? Windscribe take a very long time to establish the connection since the release of ROBERT. Before the release of ROBERT, I would get the connection establish very quick, but now I have to wait like more than 10 seconds.
Could be just you, I seem to be fine since it's release.

~LDogg
 

HarborFront

Level 46
Verified
Content Creator
Last edited:
  • Like
Reactions: Brie

windscribe

From Windscribe
Verified
Developer
Windscribe here:

We compile our block lists from over 20 sources, including Spamhaus DBL. We have a hand curated whitelist to remove false positive domains from the existing lists. The whitelist is not perfect, so we invite everyone to submit their face positives to us, so we can check and whitelist them. We've whitelisted hundreds of domains in the last 48hrs based on user feedback.

PM or post false positives here, and we will fix it. The ones posted so far will be looked at.

If you don't wish to deal with this, you can disable ROBERT in the "My Account" section.

Lastly, in terms of performance vs Adguard, NordVPN "Cybersec", PIA "Mace", and Perfect-Privacy (which has awesome block lists) see our blog: Meet R.O.B.E.R.T — Malware and Ad Blocker – Windscribe
 
Last edited:

ticklemefeet

Level 22
Verified
When I open Edge with ROBERT enabled, my start page get's blocked but when I click next tab it opened up the page. I I close Edge and open it again , the page loads fine.
Start
 

mike6688

Level 2
I have one issue for its android version.

I set it to always-on for a day and somewhere in the later part of the day a message pops up saying Windscribe is consuming a lot of power behind the scene. I did the same for Avira Phantom Pro VPN but no such issue.
Not experiencing that here. I've turned on Windscribe for last 2 days none stop since activating ROBERT. Hasn't used any battery according to device managenent on my S9. Data use has massively decreased though, which is awesome!!
 
Last edited:
  • Like
Reactions: Weebarra

HarborFront

Level 46
Verified
Content Creator
Not experiencing that here. I've turned on Windscribe for last 2 days none stop since activating ROBERT. Hasn't used any batrery according to device managenent on my S9. Data use has massively decreased though, which is awesome!!
You use WiFi or mobile?
 
  • Like
Reactions: Weebarra

Local Host

Level 17
Verified
Not experiencing that here. I've turned on Windscribe for last 2 days none stop since activating ROBERT. Hasn't used any batrery according to device managenent on my S9. Data use has massively decreased though, which is awesome!!
That is caused by how VPN works on android, in fact it's not consuming any battery, the programs that use the VPN connection add on top and give false metrics.
 
  • Like
Reactions: Weebarra

HarborFront

Level 46
Verified
Content Creator
That is caused by how VPN works on android, in fact it's not consuming any battery, the programs that use the VPN connection add on top and give false metrics.
Nope. I was trying out ExpressVPN the last day or so. Now, I'm getting the below same notification message as well

Power intensive app found

ExpressVPN is consuming power in the background.


I checked ExpressVPN and it indicates it's frequently refreshes in the background. I believe any app that constantly runs in the background consumes power. I just got another same power consuming notification from my 'Gravity Screen' app which I just installed
 
Last edited:
  • Like
Reactions: Weebarra

windscribe

From Windscribe
Verified
Developer
Messed up feature. No notifications about a blocked site. You have to contact them to unblock a website. No whitelisting features or setting.:rolleyes: I'm a bit disappointed.
It's not possible to do "notifications" with this type of blocking. You can check yourself. If domain resolves to 0.0.0.0 then it's blocked.

We've been whitelisting false positives all weekend. We're also working on the next update which will have custom white and block list support, so essentially it will function like "cloud based" Pi-Hole.
 

Andrew999

Level 22
Verified
@windscribe
When I try to update X-Sec Antivirus which is made by a user on this Forum it blocks the update when I am connected to VPN. ROBERT must be blocking it, I have malware + ads and trackers enabled.


When I disable the VPN it allows me to download the update. Here is a link to the program.

www.xsecantivirus.com




It gets stuck on this, when I disconnect it runs fine.

I posted this in Windscribe technical channel and #cosmoxl replied but I'm not sure if it's completely white listed yet.

Also I'm really looking forward to when WebRTC is blocked and City support is available for the Browser extension. ;)
 
G

Genux

How good is Windscribe when travelling to Europe? Which server do you recommend to use?