shmu26

Level 84
Verified
Trusted
Content Creator
Yes! Unfortunately. So I guess it is either Firefox or something related to https scanning?
Sometimes the user profile in the browser gets messed up. You could try this:
1 Make sure you are signed into your Firefox account and all your settings are properly synced.
2 Uninstall Firefox.
3 Do manual cleanup by deleting ALL Firefox folders in Appdata, and wherever else you might find them
4 Reboot
5 Reinstall Firefox, but do not sign in to your user account
6 Try to install add-ons
7 If all is well, sign in to your Firefox user account and let settings sync
8 If the problem returns after step 7, you might have to reset your user account to default settings, and rebuild it.
 

The Cog in the Machine

Level 12
Verified
Sometimes the user profile in the browser gets messed up. You could try this:
1 Make sure you are signed into your Firefox account and all your settings are properly synced.
2 Uninstall Firefox.
3 Do manual cleanup by deleting ALL Firefox folders in Appdata, and wherever else you might find them
4 Reboot
5 Reinstall Firefox, but do not sign in to your user account
6 Try to install add-ons
7 If all is well, sign in to your Firefox user account and let settings sync
8 If the problem returns after step 7, you might have to reset your user account to default settings, and rebuild it.
@shmu26 Thanks for the tip but, unfortunately, uninstalling Firefox did not fix the issue (I don't have a Firefox account btw). It seems that I need to contact Kaspersky support for further help. Thank you again and thanks for @harlan4096
 

The Cog in the Machine

Level 12
Verified
Uninstalling FF is not enough, You should delete manually Mozilla folder in C:\PrograData\ and in C:\Users\AppData\<your account>\Roaming\
+1
this is an important step. I haven't used Firefox in a while, but this is how I solved a somewhat similar problem with Kaspersky and Chrome, a few days ago. Simply uninstalling was not enough.
Same issue :(
I don't install extensions that much. Anyway as of now only disabling Kaspersky's protection fixes the issue.