Q&A Windows show no antivirus is active, although my BTS (Bitdefender) is active and running.

peterfat111

Level 1
Mar 25, 2021
47
Hi, guys. My windows defender says there is no anti-virus protection on my pc, but I got Bitdefender active. Anyone know why? :)
 

Spawn

Administrator
Verified
Staff member
Jan 8, 2011
21,042
Try Step 3.

Most of the times, when Security Center reports Bitdefender Antivirus and/or Firewall are turned off, it is just a display issue. In other words, while Bitdefender is working properly protecting your PC the status displayed in Action Center is showing otherwise not being able to check the real status.
 

Opc9

Level 4
Aug 2, 2020
163
Also, windows security is telling that windows security service is off, but it is on(I checked ). Anyone know why?
Have you followed all these steps?
3. Furthermore, follow the steps below to refresh Windows Security Center checking list

a) Open an elevated command prompt as follows

Click the Windows Start menu from the bottom left corner and type in cmd.exe

Right click on on the Command Prompt search result, and then choose Run as administrator.

b) In the command prompt window type the command below and press Enter

winmgmt /verifyrepository

c) You will get either one of these results:

WMI repository is consistent – no problems detected >> go to step f)

WMI repository is inconsistent – problems detected >> go to step d)

d) To rebuild the repository type the command below and hit Enter

winmgmt /salvagerepository

e) You will receive one of the results below

WMI repository is consistent – no problems detected >> go to step f)

WMIrepository salvage failed – failed to rebuild WMI repository. Try repeating step d) again.

WMIrepository has been salvaged – WMI repository has been successfully rebuilt. >> go to step g)

f) Reset the repository to its initial state using the command below and hit Enter

winmgmt /resetrepository

g) Now reboot the PC and check if the issue reoccurs
 

peterfat111

Level 1
Mar 25, 2021
47
Have you followed all these steps?
3. Furthermore, follow the steps below to refresh Windows Security Center checking list

a) Open an elevated command prompt as follows

Click the Windows Start menu from the bottom left corner and type in cmd.exe

Right click on on the Command Prompt search result, and then choose Run as administrator.

b) In the command prompt window type the command below and press Enter

winmgmt /verifyrepository

c) You will get either one of these results:

WMI repository is consistent – no problems detected >> go to step f)

WMI repository is inconsistent – problems detected >> go to step d)

d) To rebuild the repository type the command below and hit Enter

winmgmt /salvagerepository

e) You will receive one of the results below

WMI repository is consistent – no problems detected >> go to step f)

WMIrepository salvage failed – failed to rebuild WMI repository. Try repeating step d) again.

WMIrepository has been salvaged – WMI repository has been successfully rebuilt. >> go to step g)

f) Reset the repository to its initial state using the command below and hit Enter

winmgmt /resetrepository

g) Now reboot the PC and check if the issue reoccurs
yes after a reboot still windows security tells me that the service is not enabled so I followed this video
I didn't restart yet, if this is not correct then I will just go change it back. Anyone sees something wrong ?
 
  • Like
Reactions: venustus
Top